Migrating from SQL Local DB to SQL Server


I have been trying for 2 days to setup my system to use iPad (RDP setup). But now I encounter issue whereby I cannot migrate from SQL Single Local DB to the SQL Server:

  1. Previosly I’m using the SQL Single Local DB
  2. I installed the SQL Server 2012
  3. Using the database backup module, I tried to restore my single DB database to my new SQL Server environment but following error shown up:

It does not have permission to the c:\users dir. This is common. Backup to a different location other than inside users dir and then try a restore.

SQL Server express 2014 is the latest version btw


Oh… Thanks for the quick reply. Hmm should I uninstall the 2012 and reinstal with 2014?

Sorry if it become out of topic. I also patch the windows 7 professional to be able to accept concurent rdp. But whenever I try to connect the rdp session, it terminate me immediately. Any similar case?Thank you

That is not a patch. It is a hack and Microsoft regularly updates so it won’t work.

You can upgrade to 2014 no need to uninstall.

1 Like

Thanks!! I will try your solution later. I see the light in a tunnel now :smiley:

Hi @Jesse , thanksfor your help earlier on.

I did the backup and restore using another drive and its not showing the same error message anymore. However I received following error msg now:

And then I thicked the database backup module setting that said about to overwrite the database name or something. And when I tried to restore, this error shown up:

Any similar case?

Additional information on how I did the backup and restore.

I removed the database string in the local setting, logout, restart SambaPOS and then backup using the backup module.

To restore, I fill up the database string in local string, save, logout and restart. Login after that try to restork using the backup module.

Btw, @Jesse , I found a thread that has same issue with me: [RESOLVED] Restore backup - Access denied

Looks like his solution will work , I will try that solution and update here. Thanks

1 Like

Apparently my problem still persist with different error message. I even tried to create new database with the name “Temporary”

Do I need to do any changes with the database name inside the SambaPOS app?

Tried to restore using the Management Studio

New database with the name " Temporary"


To those who experiencing the same issue as me. You can fix the error by restoring the database backup using the SQL Server Management Studio, and when restoring, select “files” on the left panel and choose to set your “Restore As” folder to generic folder like C:\SambaPOS Database\ instead of inside your C:\Users.


1 Like

You beat me to it - good to hear you figured it out.

The error message is due in particular to the fact that the application (SSMS) does not have permission to the User’s folder, thus the Access Denied error message.

The reason you run into this issue is because LocalDB installs the DB files to a users folder - it is after-all a single-user database by design.

When you install SQL Server Express, it sets the data folder to a path that it can access, so you don’t really ever see this issue crop up when backing up or restoring.

1 Like