Missing Buttons in Payment Screen

Tried V3 using sample data that goes with it. Seen Cash, Credit Card, etc buttons on the right side of the screen during settlement. Installed V4 with sample data. I only see Close button occupying the whole area where the Cash, Credit Card (etc) buttons appears. What did I miss?


[UPDATE] I tried deleting the mapping and recreating it. For some reason, buttons are now displaying.

Hi, could you please tell me how to make the cash and CC buttons show on payment screen? I download SambaPOS 4.1.16 2 days ago, but that buttons are missing, so I can’t test the cash payment (and close the order).

Thanks A lot

Go to Manage - Tickets - Payment Types. Here you should a list of

Credit Card
Customer Account

Double Click on the Payment Type and Select Mappings, make sure you have * in all sections. Make sure you hit Save after adding the mapping. Repeat this for all the different payment types you require. See:

Thanks for answer, but that didn’t work. I uninstall a reinstall a new version but nothing, I delete Mapping and create it again, but nothing.

Any other suggestion?

Are you adding priced products to the ticket before going into the payments screen? If your products are null value then these buttons will appear grayed.

Did you configured foreign currency?

Hi emre, thanks for the tip, I create it but looks like that a rate of 1 disable the cash button. My question is what rate I have to put there? I want to use everything in my own currency (Or just delete de foreign currency)

Another question is, how to change the money denominations (1,5,10,20…) because here in Colombia the denomination it’s bigger

You need that function if you frequently accept multiple currencies and track transactions under different accounts. By default it works on your currency. Adding new currency does not disable cash button. It does not appear since your currency definition does not match with mapped payment account currency.

Use Program Settings > Payment Screen Settings > Payment Screen Values setting for custom denomination values. Enter values as comma separated like you’ve typed here.