Mobile Client & Message Server connection error


#1

I have searched for this issue around but can’t seem to find it.

I have installed Mobile Client Helper and Samba POS V5 (I believe it’s version 5.2.3).

Samba is already connected to Message Server because it says on POS window on the lower left part of the window with green letters.

I have opened the Mobile app on my phone, I went to settings tapped Find Settings, added ticket printing save configuration, but when I try to update or login it says Message Server connection error.

Is anyone experiencing the same issue?

I have to mention that I have Samba POS licensed but I don’t have any license for Mobile Client yet (I wanted to try it first) :slight_smile:


#2

Hello @dren

Yes, I have experienced the exact same issue when installing the new mobile client on Android this morning. My mistake was, I assumed all configuration for the Android client is the same as for the previous version, but it was not.

The simple fix for me was the point “4.4.3” section in the new Setup Manual you can find here: https://kb.sambapos.com/8-1-android-mobile-client-v2-setup/?lang=en

Look at specifically this section:
image

Make sure you have also followed all the steps line-by-line because it is different to the first Android mobile client setup! Also make sure to make BACKUPS FIRST of your SambaPOS database

Also, you HAVE to remember to restart SambaPOS Messaging Service as well as Mobile Client Helper.

Then after all the above, only then try to tap on Find Settings.
REMEMBER: You must update after returning from the Settings menu, this took some time to complete, but afterwards it was worth the wait. I have 5 Android Tablets and they all seemed to work perfectly today.

Hope this helps you!


#3

Well, I believe I did everything by the manual but I still don’t understand, since when going to settings it is fetching the info, which means it is communicating but then it can’t update or login :frowning:


#4

I changed the topic to a question category. The app works I am using it myself. You must have configured something wrong


#5

Hey @dren

I found it extremely strange too at first, and trust me, I could not update either.

If you have installed the new version of SambaPOS, a new version of the Mobile Client Helper and setup everything based on the above document, it must work. Especially the part where you setup the “PDA” user and restarting all the services.

I am holding thumbs this side.


#6

I’m also seeing the same issue. unable to connect Mobile client to Message server “Helper Server Connection error”. I have gone through every settings and still no luck. it would appear number of users are experiencing same issue.

Version details: SAMBAPOS 5.2.3 [11/25/2017]
Mobile client: V2.0.15

Following setup document used:


#7

Are you using localdb? Or full SQL Express? Also show your msg server settings. Did you disable firewall? You installed mobile helper on the same server you have message server running?


#8

Yes, i’m Using full SQL Express. I have two windows tablet running and connected to message server with no issues. I have disabled firewall before installing android mobile app. I’ll send screenshots of my settings when I’m back in my lab.


#9

Yeah, same here. I have a server where I have Windows 7 Ultimate 64 bit which is mostly used for Microsoft SQL 2014 Express and other stuff. Then I have a Windows Tablet with Windows 7 and SambaPOS client installed. Both are connected to the Messaging Server so it should be OK. Firewall is disabled on the Server. Mobile Client Helper is installed on the Server.

I’ve changed the port to Messaging Server to 9090 thinking that was the issue but it’s still the same. I removed the + in the end because with the + even server and tablet would not connect.

Messaging Server


#10

So you didn’t setup msg server according to instructions. It says to set it up as 9000+ the + is crucial and not optional as it activates the webserver portion required for gql to work.

Also for them to connect after you set it up with the + you need to enter the server ip as http://serverip that is also crucial and shown in the instructions and is the reason your other clients wouldn’t work.

It is important that when you follow tutorials you follow each step closely and make sure not to skip steps or take liberty with steps. However that Is why we ask for screenshots it helps us spot mistakes and missed steps.


#11

I wouldn’t mention the fact that I removed the + at the end if I wouldn’t follow the tutorial!

Screenshots with the + at the end:

This is shown when I click on Test Message Server Connection in SambaPOS
TestMessageServerConnection

Check the message on the left low corner:

This is what is shown on my web browser

Without the + on the Samba Message Server Tool:

This is the web browser

Check the low left corner on SambaPOS

Now I’m not saying I might not make a mistake somewhere or I might not forget something but I didn’t just tried everything from my own head. I have gone by the tutorial (which in fact never mentions the + in the end and you can see on this screenshot here:

and I got stuck on this issue that is not mentioned anywhere and I would like to have some constructive feedback on the issue because to me it seems it’s just an issue on the app due to the reason that SambaPOS client is connecting to the Message Server!

Anyways, hope that someone might find a way to help me because I would really like to use the mobile app.


#12

So you still did not follow directions. You need to set the server ip on each client at http://192.168.0.19 when you setup message server options located here:

SmartSelectImage_2018-02-11-08-12-47

PS your right about port it shows in screenshots but not reflected in the text portion of tutorial @Tayfun can you fix that please. The + for port setup is not explained properly like it was in Emre tutorial for GQL

The server ip setup was clearly explained though and it looks like you missed that part. Try setting that and let us know.

The mobile client works fine once you set it up properly.

To recap yes the + is required for it to work so it setting message server name as http://serverip in each client or it will not work


#13

You see, that’s a mistake anyone can do. Didn’t add http://

Now it works, but it is asking for a license. So there is no way login in without a license?

Thanks a lot for the help


#14

There is no way to login to your database without license. It does include a demo of its own internal menu.