Mobile Client Not contacting

Following the above tutorial step by step, Sambapos mobile client give this error “Your data is Not up-to-date, Please update”

When I click update, I get this error “Message Server Connection Error”.

I need help please. I have four licence for four android tablets.

Android device is Samsung Galaxy Tab A (SM-T285)

Are you running latest version of samba? 5.2.24 I think it is currently.

How do I check my current version. Because I installed this version about a month ago

Seen now! My Sambapos show on the title bar SambaPOS [App: 5.2.24]

Do you have message server running and it’s running and configured on port 9000+

Also turn off firewall for now. We can add forwarding later once we get it connected.

I have message server running on port 9000 I have 2 terminals connected via the message server.

Done, Still not working.

Ok so show us your settings. Show the message server settings to start with. It works I am using it right now. You have something configured wrong, lets find it.

Here is my messaging server

Do you think Mobile Client helper is still required at this stage? Because I have been going through the forum and see mobile client helper. But it is not in the download page

No it is not required. Ok now can you disable firewall and try. Also show the mobile app.settimgs if you don’t mind.

1 Like

What kind of database are you using ? LocalDB or SQL Server ?

1 Like

What IP address are you putting in to the mobile client to connect?

Can you confirm the Android version the tablet is running? According to Google it runs Android 5.1 but regional variations could occur. You can check on the tablet, go to Settings > About (on the tablet settings - not mobile client settings). It needs to be Android 4.3 or above.


Ive done it just recently for the first time.

MessageServer Service needs to be installed with a 9000+ port. Yes, with +. You set your server with a static IP and then use that IP address to connect your phone. But in the phone you use 9000 port not 9000+.

This is the only thing I found to be a bit misleading in the tutorial but if you did everything else step by step it should work.

Also it is not compatible with LocalDB it must be full SQL.


Thanks guys. I was able to get it worikg with your recommendation. I disable windows firewall

You don’t have to disable it. You can set rules to allow traffic for the ports.

1 Like

Hi Jesse, what are these rules? I need to setup the mobile client I am having same issues as above, have disabled firewall but it’s still not working.

If you disabled firewall and it’s not working then the rules don’t matter, you have something else configured wrong.