Mobilepos is not registered


It sounds like its a configuration issue. What makes you think its license issue? If it were license issue it would tell you specifically with the word license in the error.

Also you did see where he said this right?


I thougth about license, because I have V5 llicesed to and APP licensed to

I did try with EN language, I have the same problem.

Ok send me the translation TXT, I’ll translate it.

Let me know.


So did you set message server port correctly? Can you show screenshot of it?

No he fixed the license issue. Your accounts are combined now.


I would hazzard a guess the licence would have been the next issue.
As kendash says it does sound more like a config issue and since licences are in DB is app cant connect to DB/API for port or whatever reason then that issue would likely flag first.


Mobile pos will give a no license error. The error he is getting is a config error. Specifically the GQL app it can’t authenticate. So either message server not set up properly or GQL permissions are not right.


I have created a trial enviroment, same network, no firewall. I still have the same problem.
The strange issue is the message “Client “mobilepos” is not registered in the system”,
Why sould say “mobilepos”? It’s a message coming from the server or client?
Network packed are recived from server and sent to the client. I have verified it “tracking” packets on port.

Here’s the server config.


The message is likely coming from the Server. The “mobilepos” Application has not been configured in Users > Applications.

Note that the Application Identifier is the client_Id that is used in the Mobile App, and that it is probably hard-coded as “mobilepos” so it must match exactly in the SambaPOS Application configuration.

The User that you use to Login from the Mobile POS must also be configured with a Password in SambaPOS. The PIN does not work when Authenticating the Application.

After you configure the Application (and a User with a Password), you should restart the SambaPOS MessagingServer Service using the Windows Services interface. This needs to be done when you change certain things in SambaPOS, including the registration of an Application.

You should also configure the Service to run with a User Account rather than a System Account.


That is the exact message if the mobile app is not configured correctly just like @QMcKay demonstrated above. If it were a license issue it would specifically say No License Found. Make sure your device is hooked to the same network as your server. You did configure the mobilepos phone app correctly with correct server ip etc?


Hi @Tayfun ,
I have running version Sambapos v4. Planning to upgrade to v5 in order to use mobile application to take orders.
I couldn’t find relevant information on licences .

Could you advise me on following:

  • v5 license comes with mobile application license?
  • is mobile app license is only for single or multiple devices ( there are 3 waitress with devices, can I use single license for all 3 devices if it is same sambas setup ?

Thank you.


No v5 does not come with mobile app. Each device needs a license.


@kendash Thanks for the answer


This solved my problem too , I am able log in .

Thank you!


Hello, I have the same problem. Even though all the settings are correct, I still get the ‘mobilepos’ error.


That message if it is the same one means you did not configure it correctly or your firewall is on or SambaPOS was not configured correctly.


One of our technician will connect to your pc and check for the configurations tomorrow.


My server is not connected to the internet. Does the MobilePos app need to be connected to the internet to register?


Yes it does. It has to register at least once with internet after that your fine.


Got the same issue, but just notice this from my reseller:

NOTE: To use Android Mobile Client, you must install SambaPOS database on SQL Server Express (i.e. not using SQL LocalDB). You can find details in the online documentation on how to install SQL Server Express and how to change database connection in SambaPOS.


I am having trouble connecting to my server. I have tried putting in my computers IP address where it asks for the Mesage server IP, am I doing this right?