Need to search Product name by Initial letter

Please add the search product by Initial Letter to improve inputting time.
Example: Product name is: ICE COFFEE LARGE CUP
We just search by input the word: ICLC

1 Like

I am interested in this as well. But if you don’t mind me asking where are you searching for products? Are you talking about in the setup Products or the actual POS screen?

Of course in the POS screen. When setting things up we dont mind it takes time or not.

Ah so what you are saying is instead of pressing the category buttons and finding the product… you just want a search box you can type a few letters in and it bring up products?

I could see how this might be helpful for some deployments. A retail store could benefit from this. Could maybe put the search box at top similar to where Fast Menu’s go.

EDIT: Or allow the {:NUMBERPAD} input to search and display Menu Items. You can already input text using an attached keyboard.

EDIT:@emre I agree this would be a good feature and would compliment a Retail environment well. Many times bar codes fall off items or something happens and it will not read the barcode. I will not use a menu with retail ill be using products with bar codes. I have not set that up yet so I do not know how it looks in POS Screen but I am asuming a search box does not come up for instances where a bar code may have fell off.

Did you tried typing a product name on POS screen?

That works yes but being able to use Acronyms with First letters of products narrows search down better if you have massive amount of products. Example Power Stick Deoderant Typing Pow may pull up EVERY product that starts with Pow… but if we could type PSD it would pull up products that are 3 word names and the names start with P S and D

This would narrow the search down closer to the actual product.

This might be complex to implement and you would have to use a validation like if you type Pow it will just use first 3 letters of first word in the product name… but if you CAP all the letters in search like POW it will look for 3 word product names and First Letter of each word.

The all caps input could be the validation for search type to use.

You can also search by just giving a space between parts. For example s de or p s d (umm maybe even p d s) will find Power Stick Deodorant.

OK so it already does exist… THANK YOU answered our question. I didnt even think to try spaces. Good info to know and it works! just tested

@vuongduongquoc just type i c l c in pos screen and like magic it works!

After thinking about it once more I’ve decided to implemented original request but it will only work if no products already contains iclc word. Will be available on next update.

1 Like

Great. The more I explore sambapos, the more I love it. Is there any hidden feature like this one @emre?

If you really get to know rules/actions etc… you can uncover stuff @emre didnt even know was possible. That is the true hidden feature of this program.



I’ve tried doing this but nothing appeared when I type the name of the product in the POS screen. Is there any settings I need to activate in order to use this functions?


No need to “activate” anything.

Give us some screenshots of your products, menus, and where you are typing and what is shown on the ticket screen…

here. i have too much product, like over 1000 and i used barcode scanner to find them. but sometimes there are item that dont have barcode where i wish i could type in to search. please enlighten me on this. thanks :slight_smile:

Try using only lowercase letters (turn off your Caps Lock).

i found the problem.
it seems like you have to wait for 5 minutes due to the new 500 products.
after restarting sambapos, it still work (i thought that each restarted will need to wait 5 minutes for it to work).
and yeah, it works by using only lowercase letters. it would be helpful though if it can be used with uppercase letters.

thanks :slight_smile:

Ar you using SQL express or ce?

SambaPOS supports searching by initials. So you can search Toasted Bagel Jam with TBJ.

However there is a small issue for V4. If you use \r for line breaks it won’t work as expected.

5 minutes waiting a little misleading. After adding new products you need to logoff / login to refresh menu cache. Even with ten thousands of products it should work fine.

1 Like

you’re right. sorry about the misleading informations. i tot i have waited 5 minutes but it was when i used small caps it work immediately. cheers everyone :slight_smile:

I have some problem. Because I couldn’t get WAMP to work, I disabled the SQL Reporting service yesterday to test and i forgot to turn it back on, now i can’t search product while typing the onscreen keyboard. I start back the SQL Reporting services, and it’s not working. :-S I wonder where I have gone wrong.