Network sharing and password issues


I am using Samb POS on two PCs on the home network. For some issues the PC which hosts the SQL server crashed and once I rebooted the PC, I was unable to log onto the SQL database from the secondary pc.

Later on I tried accessing the primary pc (hosting SQL database) through the secondary pc, there was a prompt asking for a password (which wasn’t required previously). I tried a couple of things to resolve this issue which didn’t work. For instance: in Control Panel\Network and Internet\Network and Sharing Center I Turned off password protected sharing.

I also tried adjusting some security options in Configuration > Windows Settings > Security Settings > Local Policies > Security Options and in ‘Accounts : Guest Account Status’ I ‘Enabled’ in the column. But it keeps on asking for password.

I would really appreciate it if someone could guide me on how to resolve this password issue after which I presume I will be able to access the SQL server through the secondary PC.

Thanks a lot!

Widows shared has nothing to do with samba, SQL works on completely different ports.
Have you opened ports on firewall on the hosting machine?
Try disabling the firewall temporaraly and try again.

If not helping try pinging the server from the other machine - should be ok as asking for password but good thing to double check.

Depending on how you configured SQL you would either use SQL password, user= sa and password you chose in mixed mode, if windoes auth mode the easiest thing is to ensure the user on the server and slave machine are identical.

Will check it out and get back! Thanks a lot!

Did you configure the Data Connection Strings correctly can you show some screenshots of them? Are you able to connect to the database using MSSMS?

I find it odd that it would prompt for a login… SambaPOS would never prompt for a login it would just fail to connect. This leads me to think you never set them up correctly to begin with. Can you share more information of how you set it up and the expectation you have?

Hi i’ve seen the problem that Jawad has posted.

The firewall is disabled.

Basically the issue is that the multi server SQL was functioning well. All the PC’s connected to the server, and the server itself were using Windows 7 - and were able to connect with the main server. When this was happening the server could also be accessed by typing “\SERVER” where server is the Network PC name - there were no password prompts.

However, once the PC crashed and after the reboots the server couldn’t be accessed by typing “\SERVER” and the same connection strings that were working previously are not working now.

I think resolving the password prompt issue - when accessing the server - will resolve the issue. I’ve had a similar experience in the past as well which was resolved when the password prompt was removed.


I think so - please see the screenshots.

1 Like