Open Cash Drawer Help (Ithaca Itherm 280)

Looking for some help here getting the cash drawer to open. Its driving me crazy.

Printer: Ithaca Itherm 280
Cash Register:

Tried all standard codes: 27,112,0,48,251 27,112,1,49,251

Nothing is happening. I do know the command is sending because I have had printer activity from the automation command. Is it possible that the cash drawer needs a different the pulse on a different pin? Not really sure where to go next.

Printer manual:

Your codes don’t seem to match, it’s p or 1 or 48 or 49 no?


I believe I tried some of those too but I’ll try again when I get home. Thanks.

Do you think it matters if it’s running in emulation mode vs it’s native mode? I have the printer if Epson TM88ii mode.

I went through the same thing months ago. See if you can kick it from the driver settings/config iteslf.

I scoured everything I could and collected kick codes and narrowed it down to 15 unique ones. These are for Epson, but I guess it’s worth a shot.

Here’s a tool import that creates an automation command button visible on ticket that you can go through and see which kick code works (if any). Separate templates and print jobs are created. If one works, check the print job associated with the letter selected for the kick code. (1.8 KB)

ignore the error popup - no printer installed

Thats a great idea. I loaded this in and none of them worked. Ever once and a while the printer will throw up some a single symbol, but thats it. Thats what has me thinking if its an issue with emulation.

Try the following codes might not work but worth a try

(numbers in 3rd column are drawer kick command, 4th column is cutter command)

Alternatively 27,112,0,25,250

I think I know what the issue is. The cash drawer provides a hard wired RJ11 connector, however the printers come with an RJ12 interface. The printers came wired Ithaca drawer mode configuration and I’m pretty sure its not getting a pulse on pin 1. I’m ordering a new cash drawer with an RJ12 interface to see if that works. All the cash drawers I’ve had came hard wired with RJ11 connectors.

If I’m wrong or missing something let me know.

Ithaca manual regarding printer drawer interface:

Bottom of Printer:

Cash Drawer Hard-Wired Cable:

Printer Cash Drawer Port:

Maybe you can get some RJ12 cable ends and rewire it yourself.

Very true and I did think about rewiring. At this point new registers wouldn’t be bad and for $60 a piece it’s a cheap investment.

I have one on order and I’ll post up if that fixes it.

Surly that’s where the m parameter is meant to come in…
6 pin Rj12 seems to the the unusual option, pretty sure I’ve only ever had 4/6 on all cash drawers I’ve handled.

So according to Ithaca’s website it comes with an RJ11 port, so I’m not sure if I’m misunderstanding that based on the programmers manual. I just received the RJ12 cash drawer and nothing is opening it. All I get is some spittle from the printer. Going to move this over to a printer not in emulation mode and see if that changes anything.

Update: Nothing worked under non-emulation mode. I’m starting to wonder if the Ithaca pin configuration is just so off from other providers and everything is setup to work for epson.

FINALLY! I had to remove the interface card and move the wiring harness to EPSON. After doing this the following code works.



1 Like

so much for “plug-n-play” :man_facepalming:

Tell me about it. I’m guessing most drawers are configured for Epson or Star. At least the printers support multiple pin configs.

@josephrussell can you email me the things you really need for your location with the card processing. I will be wrapping up a trip to Houston today and when I get back I want to focus on your input on the things we need to solve for you. Your input is very important to me.

I’m just adding that after changing the cable harness to EPSON the other cash drawers with RJ11 function properly.