Over 90 secs slow print job

how to troubleshoot slow print job?

video of how slow here

So far I have tried:-

  • move the sticker print job to till printer, it prints immediately

  • test print from windows, it prints immediately

  • observed the print job takes 60 secs to show on windows print queue, then another 30 secs to print.

  • clear up spool files in C:\Windows\System32\spool\PRINTERS

  • set the print template to empty, it took over 90 secs to print on both printer.

  • reindexed and maxed the columns using maintenance, took 90 secs to print

  • set sqlserver database to grow 50% on size

  • changed USB cables and ports

  • upgrade to latest print driver HPRT LPQ58 2022.2

  • updated to 5.5.2

Try looking for un-paired brackets in your printer templates (),{} or [].

negative - if it is un-paired then print speed wont be normal when switched to till printer

First is it a networked printer? Usb? What is your template?

all usb

i thought it might be baud rate issue?

Baud rate is not relevant to USB printer, unless you are printing it with a virtual COM port via USB, which ideally you want to avoid. If you have to use a virtual COM port with this printer, set the baud rate to the highest possible, e.g. 115200 or higher.

Also from your video definitely it looks like its not being sent to the printer and SambaPOS is doing something, however this doesn’t rule out the driver is somehow not responding to SambaPOS.

I notice it prints on the receipt printer as well as the label printer (and the labels seem to be blank), could it be there is an issue there as you only show the print queue for one printer?

Also I notice there is some sort of status monitor program running, I’ve never needed such to be running and should not be needed or have much use, I would suggest removing this and see if it makes a difference:


1 Like

See if this helps: Remove the printer definition from Sambapos, uninstall the printer in windows, re-install the printer then add it back to Sambapos using the local name of the printer. Restart after each step.

I’m assuming you have tried a different usb cable with that printer.

Could be something sambapos is finishing first before sending the print to the spooler. There is a lot of unknown to us to really help. We can provide guesses as you can see. The more you share the better we can give answers.

IT really looks like maybe your executing a sscript or something? Or some automation before it executes the print job. Can you share with us anything?

I dont think it is script or template issue, as I have changed to use Till printer that prints immediately on the same template.

I have tested the sticker label printer on another sambapos system on different host hardware still showing the same issue. However I havent had chance to bring a new sticker label printer to the sambapos server in question.

I am now 90% certain it could be the sticker printer itself acting up.

1 Like

It could be. Usually it’s driver related.

ended up changing ssd and reinstalling windows os and it works fine since then

could be ssd hardware issue