Please restart application. Current problem saved to log file


#1

I read about this problem but i can’t solve it, please can you help me ?

14-03-2019 21:22
License settings restoring for ::False
######################### E N D #########################
14-03-2019 21:23
-----------------------------
[General Info]

Application: SambaPOS
Version:     5.2.18
Region:      en
DB:          SQ
Machine:     BARDELTIOSERVER
User:        Usuario
Date:        15-03-2019
Time:        0:23

User Explanation:

Usuario said ""
-----------------------------

[Exception Info 1]

Top-level Exception
Type:        System.Data.SqlClient.SqlException
Message:     Cannot open database "SambaPOS5" requested by the login. The login failed.
Login failed for user 'BARDELTIOSERVER\Usuario'.
Source:      .Net SqlClient Data Provider
Stack Trace: at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, UInt32 waitForMultipleObjectsTimeout, Boolean allowCreate, Boolean onlyOneCheckConnection, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionPool.TryGetConnection(DbConnection owningObject, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource`1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection)
   at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.ProviderBase.DbConnectionClosed.TryOpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource`1 retry, DbConnectionOptions userOptions)
   at System.Data.SqlClient.SqlConnection.TryOpenInner(TaskCompletionSource`1 retry)
   at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource`1 retry)
   at System.Data.SqlClient.SqlConnection.Open()
   at FluentMigrator.Runner.Processors.GenericProcessorBase.EnsureConnectionIsOpen()
   at FluentMigrator.Runner.Processors.SqlServer.SqlServerProcessor.Exists(String template, Object[] args)
   at FluentMigrator.Runner.Processors.SqlServer.SqlServerProcessor.SchemaExists(String schemaName)
   at FluentMigrator.Runner.VersionLoader.get_AlreadyCreatedVersionSchema()
   at FluentMigrator.Runner.VersionLoader.LoadVersionInfo()
   at FluentMigrator.Runner.VersionLoader..ctor(IMigrationRunner runner, Assembly assembly, IMigrationConventions conventions)
   at FluentMigrator.Runner.MigrationRunner..ctor(Assembly assembly, IRunnerContext runnerContext, IMigrationProcessor processor)
   at FluentMigrator.Runner.Initialization.TaskExecutor.Initialize()
   at FluentMigrator.Runner.Initialization.TaskExecutor.Execute()
   at Samba.Persistance.Data.Migrator.DoMigrate(String connectionString)
   at Samba.Persistance.Data.Migrator.DoMigrate(CommonDbContext context)
   at Samba.Persistance.Data.Initializer.Migrate(CommonDbContext context)
   at Samba.Persistance.Data.Initializer.InitializeDatabase(DataContext context)
   at System.Data.Entity.Internal.InternalContext.<>c__DisplayClassf`1.<CreateInitializationAction>b__e()
   at System.Data.Entity.Internal.InternalContext.PerformInitializationAction(Action action)
   at System.Data.Entity.Internal.InternalContext.PerformDatabaseInitialization()
   at System.Data.Entity.Internal.LazyInternalContext.<InitializeDatabase>b__4(InternalContext c)
   at System.Data.Entity.Internal.RetryAction`1.PerformAction(TInput input)
   at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabaseAction(Action`1 action)
   at System.Data.Entity.Internal.LazyInternalContext.InitializeDatabase()
   at System.Data.Entity.Internal.InternalContext.ForceOSpaceLoadingForKnownEntityTypes()
   at System.Data.Entity.DbContext.System.Data.Entity.Infrastructure.IObjectContextAdapter.get_ObjectContext()
   at Samba.Infrastructure.Data.SqlData.EFWorkspace..ctor(CommonDbContext context)
   at Samba.Persistance.Data.WorkspaceFactory.Create()
   at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.get_Workspace()
   at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.ShouldCreateData()
   at Samba.Presentation.Services.Common.DataGeneration.DataCreationService.CreateData()
   at Samba.Presentation.Bootstrapper.InitializeShell()

-----------------------------

[Assembly Info]

#2

It can’t login. Make sure SQL server is running.


#3

thank you Jesse, but, yes, sql is running. and the problem still is.


#4

Its pretty self explanatory. It cant login. So check your login credentials. Make sure your using correct password etc.


#5

Login failed for user ‘BARDELTIOSERVER\Usuario’.

Make sure your info is correct.


#6

Hello jesse, i cant even have the access to the program. I never change the password. and the information what you give me its correct i check it. what can i do ?


#7

There is no magic we can do. Either the service is not running or your login is wrong.


#8

ok, sure you re right but how can i fix it ?


#9

You may want to Google SQL server connection issues.


#10

in truth, I do not handle that. how can i check it?


#11

I came across a similar issue like this before.

Strangely started happpening after a windows update.

However the client i fixed it for, didnt have user ‘sa’ enabled.

I enabled it, applied a password.

Tested in management studio to ensure i can login.

Then added the username and password ro sambapos.

That fixed it.

Hope this helps


#12

Hello, may i ask you if you could explain me step by the step the procedure ? it would be kind!


#13

Try that maybe that will help. I just typed change sa password in google.


#14

at least i uninstalled sambapos y sql.
I install it again.
Now i can open sambapos. But i can not restore the database back up

Can you explain what i ve to do ?

“sql server don´t have permision to access to backup folder”
that´s the message that i have…


#15

It is what it says.
Either use a different folder for backups, outside of user folder recommended.
I have a ‘Till Stuff’ folder in root of C drive which i keep all the important stuff including backups.
Inside users folder is permissions restricted heavily by default.
Move outside users folder and if need grant SQL permission to the backups folder by adding a permission for NT Service\MSSQL$InstanecNameHere ie NT Service\MSSQL$SQLEXPRESS


#16

Yes i create a folder for backup in root of c, but the access is still denied.
How can i add a sql permision ? i didn’t get it…
Sorry i manage a little restaurant, i’m a cooker, i don’t understand a lot from sql stuff!


#17

Right click the folder, in security/permission for folder use the above to add permission for your SQL instance.
The user check Windows should check before you add anyway.
You need to check your instance name as it may be different to that above.


#18

Ok, i ve one hour to fix the problem. Someone can help me, with teamviewer perhaps?
I m disposed to pay of course, just tell me how and let’s do it.


#19

didn’t work o didn’t do the good thing, i don’t know.
i don´t understand what happen, i need to fix it quickly.


#20

Make a folder c:/backups
Right click that folder.
Go to security/permissions tab
Edit/add a permission
When it asks for user enter the nt service as above with the instance but changed to your instance name in SQL.
If you get it right it will sorted and underline it. If it’s wrong it will tell you so.
Add the service and give full control.