Port Printer appears to be fixed at 9600 baud

I am testing a customer display based on a question someone had on the forum. It is an LED8 display I had lying around and as someone asked, I thought I was just see if I can get SambaPOS to work with it.

I can get it working fine via command prompt. The customer display comes on at 2400 baud, even it can be set to 9600, it goes back to 2400 when powered on again.

So I have tried setting Windows settings for the COM port (COM2 in my case) to 2400, but SambaPOS won’t send to it. If I send a escape command to the COM port to change the display to 9600 mode, then SambaPOS will send to it, EVEN if my Windows settings are set to 2400 !

So it would appear SambaPOS has a built in setting that assumes the COM port speed will be 9600. Is there any way I can override this? I want SambaPOS to send using 2400 baud, or at least following Windows setting.

Note I am testing this on SambaPOS V4.

@emre can you comment on this if it is indeed hard coded?

Hmm I was assuming it automatically follows windows configuration when baud rate not set explicitly but seems like it defaulted to 9600. I’ll check that.


@emre is this resolved in 5.1.46 release?

Yes it’s reading baud rate from windows port setting.

1 Like