Possible bug in the current version

Hi guys we believe we have found a possible bug in the current version 5.3.6

We had enabled script debugger for a client and now have disabled it. However the script debugger still runs in the background. Have restarted sambapos and the computer but on restarting sambapos it keeps starting again.

Could some one please help.

Thank you in advance.

Edit: I have even tried to uninstall and reinstall sambapos still keeps running even though its disabled.

Script debugger setting is stored in SambaPOS’ ProgramData folder:


The node name is EnableJsDebugging. Make sure it’s set to <EnableJsDebugging>false</EnableJsDebugging>

THank you i’ll give that a go now.

Just looked into this file it says false there but still have debugger running even after killing the app and restarting the computer. I have also tried uninstalling and reinstalling sambapos.

if it looks like this:

then the setting you’re looking for is the Rule Debugger:


in the settings file it should be this: <DebugRules>false</DebugRules>

No I think he’s talking about script debugger it is different than rule debugger.

Sorry I was wrong its the rule debugger i have now disabled that too but still cant get rid of it

1 Like

It should disable once you close sambapos completely and restart it after turning it off. SambaPOS has to be completely shutdown for it to disable completely.

When I tested it… it turned off just fine. Be sure you press save after unchecking it and be sure you close sambapos completely and restart it.

restarted the computer once again and it worked. thank you so much

1 Like

Yes is a bit anoying but you have to close sambapos down completely and restart sambapos. You didnt have to restart the computer however that does the trick too.

i tried restarting sambapos but that didnt work for me hence tried restarting and it worked.

1 Like