Prevent entity screen from refreshing on open

I have a web browser open in an entity screen and every time I open the entity screen it removes everything loaded and goes back to the home page.

Is there a way to prevent this and allow me to stay on the page I last went to?



Uncheck Auto Refresh in the Widget Properties.

tried that, but when i log out of the POS and back in…


Nothing you can do about that. The Logout/Login sequence clears the Cache by default. It is like closing the Browser and re-opening it.

You might try setting this to False for your Logout Rule/Action, but I suspect that will not have the desired effect in most every other case of your system operation, so I do not recommend it …

Maybe you need to change the URL in the Widget if there is a specific area of the website that you want to navigate to ?

na, its playing music… it resets it.

Ill just explain to the client that they should only go in when music stops of they really want to change it. No biggie.


I don’t have this Action… am i meant to?! :sailboat:

Logout User? By default, no, the Action will not be there… you need to create it.

The Logout button/Tile does not require the Action (and no Rule either) because it uses the Navigation settings to fire the Logout Module, which logs the user out.

Again, I do not recommend this. It will break your system in many other ways - that is, the expected behavior of your Automation will be affected in ways that we cannot begin to predict.

ill not do this, i promise :thumbsup:

I added an underscore to the entity screen name in the action… it still takes me there but never refreshes…

probably not meant to do that but ill not complain :slight_smile: