Printer cut issue


I’m new on sambapos and I find your work really excellent and I look forward to using sambapos in my restaurant. I have an issue with the printer. For test I use the standard template of sambapos and when I click on “print bill” the printer (Custom Kube Lottery) print the bill but doesn’t cut the paper. I set driver in windows to cut when document is end and if I print a document on Word is cutted. I try to add in the ticket template and does not work.

Here the template:

-- General layout
<L00>Ticket No:{TICKET NO}
<L00>Ticket No:{TICKET NO}
[<J10>Total Gift:|{ORDER STATE TOTAL:Gift}]
<J10>Total:|{TICKET TOTAL}
<C10>T H A N K   Y O U




-- Default format for orders

-- Format for gifted orders

-- Nothing will print for void lines

-- Format for order tags

-- Table entity format
<L00>Table: {ENTITY NAME}

-- Customer entity format
<J00>Customer: {ENTITY NAME} | {ENTITY DATA:Phone}

I try to change printer type in ticket printer, raw printer, windows printer, text printer and HTML but the problem is the same. Can someone help me?

I found this manual on the internet, I do not know if you can help:

P.S. I run windows 7 x64 and sambapos 4.1.82

Show screenshots of those Printer Settings. Does it cut the paper when you print a test from Notepad? In general, the paper cut is a function of the Printer Driver and not a function of SambaPOS.

Stay with Ticket Printer until you have this resolved. Then you can possibly try other printer types.

In some cases, you may need to send an <XCT> cut command or <CUT> command to the printer within your Template. But first verify whether or not it auto-cuts when test-printing from Notepad.


thanks for help. Here the screen of printer settings

the printer cut with a notepad document.

No one can help me? I try to print a notepad document and the printer cut the document. I type in the template the command <CUT> but not work. Other ideas?

Youll need to find the XCT command, usually a set of numbers that tell the printer to cut. You would insert <XCT>(command numbers) at the end of your template to tell the printer to cut

Youll need to read your printer documentation or search google to find that code

What printer is it? I have mine set in the printer driver and it works fine

1 Like

Hi @RickH
My printer is a custom kube lottery. I found this in the internet:

Is huseful for the <xct> command?

Try <XCT>27105 at the bottom of your printer template, put a sale through and see if it cuts

1 Like

It WORKS! Thank’s a lot @RickH you solve my problem!

1 Like

QMcKay suggested that you must have missed it.