Printer get stuck! On ticket and report

Well i searched for similar problems and it was told the sambapos user that it might be some value that cause it to just stop.
Well i tried to narrow down which product but it doesn’t seem to make sense since i took out random things and it printed, so i assume its the number of products or the total sum of the bill perhaps still i cant tell to take a look and fix it.
It happen on a report printing as well, so im very confuse.

Thank you guys for advance!

 -- General layout
 <C10>Cr 37 # 10 - 29
 <C10>Telefono: 034-2664547
 <C10>NIT: 9008150501
 <J00>Fecha:|{TICKET DATE}
 <J00>Factura:|{TICKET NO}
 [<J10>Total Gift:|{ORDER STATE TOTAL:Gift}]
 <J10>Sub Total:|{PLAIN TOTAL}
 <J10>Total:|{TICKET TOTAL}


 -- Default format for orders
 -- Format for gifted orders
 <J00>- {QUANTITY} {NAME}|**GIFT**
 -- Nothing will print for void lines

 -- Format for order tags

 -- Table entity format
 <J00>Mesa:|{ENTITY NAME}

 -- Customer entity format
 <J00>Customer: {ENTITY NAME} | {ENTITY DATA:Phone}

 <J00>IVA 16%:|{TAX TOTAL}

Thats my ticket tamplet,
Here is a notepad record of one of the tickets not working:

> ░░░░░ B U B A   B U R G E R S   B A R ░░░░
>              Cr 37 # 10 - 29              
>           Telefono: 034-2664547           
>              NIT: 9008150501              
> ------------------------------------------
> Fecha:                            9/1/2016
> Hora:                              8:41 PM
> Mesa:                                   B8
> Factura:                                95
> ------------------------------------------
> - 2 Hamburguesa Argentina        35,800.00
> - 1 Ad.Michelada                  1,000.00
> - 1 Cerveza Nacional.Pilsen       5,000.00
> - 1 Gaseosas.Pepsi                3,500.00
> - 1 Hamburguesa Classic          13,900.00
> - 1 Tomate                            0.00
> - 1 Lechuga                           0.00
> - 1 Ad.Tocino                     2,000.00
> - 1 Ad.Queso.Mozzarella           2,000.00
> ==========================================
> Sub Total:                       63,200.00
> Propina %10                       6,320.00
> Total:                           69,520.00
> ==========================================
>           GRACIAS POR SU VISITA           

Thats how my recipe looks like printed:

Here is how it get stuck… the printer doesnt even cut the paper:

Thats a close report that was printed:

Thats a report who got stuck:

Can you show your Print Job?

Just happend again while printing the report

And this is the report in demo note

Buba Burgers Bar
Work Period Report
01 September 2016 11:55 - 01 September 2016 22:56
SALES TOTAL                     315,500.00
Propina                          26,130.00
SALES TOTAL                     341,630.00
Cash                   %100.00  341,630.00
TOTAL                           341,630.00
         General Information              
Extra Item Properties                    -
Order Count                             48
Submitted  (48)                 408,600.00
Void  (15)                       93,100.00
Paid (11)                       341,630.00
Ticket Count                            11
Sales Total / Ticket             31,057.27
                User Sales                
Asaf                            341,630.00
              Item Sales                  
Hamburguesas            %55.09  188,220.00
Bebidas                 %27.67   94,540.00
MasParaComer             %8.31   28,380.00
Addiciones               %4.13   14,100.00
Entradas                 %2.87    9,790.00
Postres                  %1.93    6,600.00
ArmaBurger               %0.00           -
TOTAL                           341,630.00

Before I think its samba, I’d like to think possibility of printer issue. Either with connection, the way the driver is installed, printer head, even possible no enough power in adapter of printer or fluctuating power.

I recall having an issue with printing on one of my newer thermal printers, the issue I had was that everttime I would try a print, the printer sometimes fed the paper sometimes it struggled as much as not even printing… Later I found out the power adapter voltage wasn’t enough …

Firstly… Have you got another printer to test if its doing the same thing?


Im thinking it may be driver issue. Try uninstalling printer and installing latest drivers.

1 Like

Well i had two but i returned one,
Since it happen so random but when it does it happen only in a specific ticket or report i find it weird because if it would be a printer problem it wouldnt print another tickets while the one it had an issue it just wont print no matter what i do.
the other day i just took out products and once i did it just worked, seems like the heavy bills makes the most of the problems.
But i will uninstall the driver and printer and see if it helps.

Thank you guys for your time.

But your report example shows its not ticket specific…
I would agree with my guess being printer or driver issue.
What printer is it?

Ok i have done that,
installed the printer all over and lets hope thats the case, also switched to another usb port just in case.
This printer is an IBM 4610-1NR , its also a Toshiba model… so im using Toshiba driver.

Well the problem isnt gone, still occurring when the ticket is busy with stuff… when there is a table with alot of orders its just doesnt print.

Not sure what your expecting me to say.
Im pretty sure its not samba related…
Youve had 3 responces saying its down line of drivers…

Drivers -> Cable -> Printer

Do you only have one machine? Dont have a spare/second printer you can swap out to test?

If there is an error during Printing that is SambaPOS related, you will see an error message on the screen indicating there was an error printing and that you should check your Printer configuration and Printer Template. There will also be an error logged in the SambaPOS log file, located here:


When it “doesn’t print”, look at the Windows Printer Queue for the printer. If you see any jobs listed there, then SambaPOS has done it’s job, and the Printer/Driver itself has failed to print.

1 Like

Hmmmm, although if its the printer itself it might pass through que.
You ideally would want to have que open when printing to see print job come out of samba into que then clear.
The fact it has been printing and failing half way through the print strongly suggests its down stream of samba.

1 Like

Next time i´ll do that, but on the other hand it kinda weird since when i take a order from the ticket and do print again its just goes fine and on bigger tickets i happens most of the times.
I will look after what you just mention and check this thing…
Thank you guys so much.

Sounds like a hardware failure. Somethimg is failing on large tickets.

Can you even print self test? Try print report and if it stop then try self test right away. It seem like hardware overheat.

I really dont know whats print self is, but its not showing any problem in the SambaPOS nor where it shows the print jobs.
So i made a video … to show you guys how it goes its kinda funny but im kinda hopeless
Thank you for your time!!
appreciate it! (7.0 MB)

Of course, because it is not samba problem. It is your hardware problem. Just google how to do self test on your printer. For epson (may be most of pos printer), switch printer off, press and hold FEED button then switch on while holding feed button.

1 Like

You can create text file with 100 lines and use notepad to print and see if it print correctly.
This is test print line 1 This is test print line 2 ... This is test print line 100