Printer setup problem


#22


#23

Ok, so couple of things;
Most things are case sensitive, your print job in action is Print Bill, your print job is called Print Bill, may be a factor or might not but rename job to Print Bill.

What i expect is your problem is the state settings in the job, girstly normal/defalt print bill option doesnt have a state filter as you want to print everything. Kitchen print filters to new in order to only send new orders rather than every order each time.
Default print bill action only has the job set.
Additionally even if you were purposfully wanting to filter, unless you messed with states also ‘Status’ is not a default state for Status in the flow.

These are the default actions;

You may need to remove the action from the rule, save, close then readd the action to refresh it within the rule.


#24

Status is not a state it is a state group. It would never meet that setting. Example is New is a state of Status so if you put New for order state it would print only if order has a state of Status called New.


#25


#26


#27

So you only want it to print on gift state? It doesn’t matter what’s in the drop-down. Remove the state and see if it prints.


#28

No But I am not getting any other option


#29

It doesn’t matter you can type anything you want there. New, Paid, etc

I’m saying remove it completely see if it prints.


#30

I removed and tried but did not work
and again add new and saved still when I hit print bill dose not happen anything


#31

Show you print bill button settings also, if you have changed print action options maybe something there too.

Also just check the mapping, set a , mapping line


#32

When you make the change you have to remove the action from the rule save it then open the rule and add the action again or it won’t work.


#33


#34


#35

Also just to double check, since you have specified server for terminal in mapping, server is set as terminal name in local settings right?


#36


#37


#38


#39

No in local settings… have you made sure that machine is set to server as terminal name?


#40

Also presume the mapping on the rules is set to default *s across the board?