Printing a report with nicer headers on thermal printer

Hi there,

I try to make my workperiod report nicer.
(the same tables headers and subheaders than the visual one : white text on black background)

I print it on a Thermal Printer.

I think I had it once printed out exactly the same way it is displayed in the report section.
But I cannot do it anymore.

I’d like it printed out like the right one (but complete of course)
Right one : visual printing : Checked
Left one : unchecked.