Problem with submitting new ticket in V5 with backup from V4

I am having an issue with testing my setup on V5 if anyone can help please.

I have installed V5 and then restored my backup from my current live V4 everything appears to be in place ok but I am having 1 issue at the moment…

If I add items to a new ticket then click ‘close’ to submit the order nothing happens… (With no items added or if I cancel the item I added it will then close.)

I am a bit rusty as I have had V4 up and running for 18months and since all the initial setting up, I haven’t had to go in and change anything as it has all worked perfectly and now I have forgotten most of what I had learned :slight_smile:

any help would be great as I would really like to get V5 implemented without having to build again from the beginning.

You can only close a Ticket if it has an Entity assigned to it, or if it has a Ticket Tag set.

I first click on an entity then add the items to the order. Does V5 do something different to V4 with regards to how this works ?

Nothing different.

Check your Close Ticket Rule to ensure it is mapped and that the Constraint for Automation Command is set properly.

You might need to Upgrade Old Rules which is a button located in Settings > Program Settings > Maintenance

1 Like

thanks for your help - I have tried that and still the same. I’ll keep plodding through the rules and see if I can spot anything.

Do you have any constraints on the close button rule/actions?

Troubleshoot with Show Message action. Put one of them in each of the Events for:

  • Automation Command Executed, for Close button
  • Before Ticket Closing
  • Ticket Closing

Some Rule is preventing it.

1 Like

I had a problem like this recently. It was because I had my “Tables” Entity Type set as Sales Accounts under the Accounts tab.

Should be blank

I’ve had this issue my self, I had created a ticket tag for the number of customers at a table, had selection required as un-checked, but when I hit close nothing happen either. If I gave the number of customers tag a value it would allow me to close the ticket. If I removed the mappings for the ticket tag I was still unable to close the ticket. When I debugged with the show message rule nothing was firing after the ticket close ticket action, and no actions fired in the the ticket closing rules.

So now currently the staff have to enter the number of customers at a table, which isn’t that bad a thing, better for my reports.

Just my 2 cents.

You are a star! Sorted … Thanks for your help! Changed from sales to blank and is now working

It was all @emre. Sent him my database and he found the problem in like 5 seconds!

Thats now fixed but just noticed that I get the same thing if I 're-open a closed ticket … Clicking close does nothing! Back to further investigating :smile:

Check enabled states on the close automation command button & rules