RDP problem with second user

I followed this guide:

When I am logged in with the primary user account Samba works. But when I log in with the second account intended for the RDP terminal I get this error when I open Samba:

The user Terminal has Admin rights. During installation I configured SQL express to work in Mixed mode and did everything as described here:

Did you enable Mixed Authentication mode?
From screenshot, doesn’t look like you have user parameter.

1 Like

@sukasem is probably right but without seeing the whole string can’t say for sure but if you are using SQL express and RDP is is most likely your connection string which is the issue.
This wouldn’t be an issue but a config error. Issue is for reporting bugs and this is a common setup which is known working so not an issue but a question. I have taken the liberty of moving to question category.

1 Like

Data Source=SOMA-PC\SQLEXPRESS; Password=sambapos; Database=SambaPOS;
Here is the whole string. I tried creating another terminal user, but it still doesn’r work.

I get this error when I try to change options in the managment account trough the Tablet user.

User ID???

User Id=sa

1 Like

is it working? look at this

1 Like

Look for this…


Sorted by Description column …

1 Like

**Data Source=SOMA-PC\SQLEXPRESS; User Id=sa; Password=sambapos; Database=SambaPOS; **
Login failed for user ‘sa’.
When I remove user SA it works on the main account. In MSSMS I added the user MYPC\Tablet and I can login, but I when I try to open the POS screen it says no valid licence.
I followed steps 3 and 4 from this guide but SA user still doesn’t work. Common Database Connection Issues - How to resolve them

The SQL processes are running.

Are you sure your Instance name is “SQLEXPRESS” and not “MSSQLSERVER” ?

Did you enable Mixed-mode authenticate and set a password for the “sa” account?

Can you attach using SSMS?

1 Like

Problem solved. In SSMS I changed the default schema of the tablet user for my database to dbo.