Receipt doesnt print £ sign instead it has been substituted with ae

Ive just copied my database to my PC and i havent touched the receipt settings and even though in my templates I have the £ symbol to print (which it used to) all of a sudden it no longer prints £ and instead prints what looks like ae?

Any ideas why all of a sudden my £ sign does not print?

Check the character set (codepage) of the Printer in Manage > Settings > Printers ?

says 857? ive not changed this does that sound right? i have an epson TM-L90

857 is Turkish

I use 437

It could possibly have something to do with the character set being used by the printer driver as well.


just tried 437 and that hasnt worked, i dont get it as i havent changed anything to do with tickets or printers, it was always 857 and it did worked.

Ill have to keep playing around with it

any ideas @emre @Jesse ? 437 is the UK/USA character set but doesnt work for me. I dont know why the £ symbol has stopped printing and has been substituted for something that looks like “ae”

I havent changed the character set before and the £ symbol has always printed so i dont know what has caused it to stop

437 is correct code for UK. Can you also check the printer language/code settings via the Printer Utility/software. i know printers also have the code settings.

There must be an echo in here :stuck_out_tongue_winking_eye:

1 Like

i cant find anything to do with language/code settings in my printer driver???

What make and model is your Printer?

Anything different about your Windows Regional Settings on your PC as opposed to your “other” computer that you transferred the DB from?

You don’t have anything in the Char Replacement field, do you?

as far as i know windows regional settings are the same, ive been transferring from my laptop to my touchscreen pc for ages when im testing and this hasnt happened before

im more than likely using the same printer driver as you, i used to have the TM-T88IV and im using the same drivewr as i did for that

Ok, I understand what you’re saying… no known changes, and things suddenly stop working like they used to. Frustrating to say the least. Let me give you a quick scenario…

The Laptop I use was sold in the Canadian Market, and from time to time, suddenly certain characters on my keyboard start displaying incorrectly when I type. For example, ? becomes E. This is due to some type of French character replacement that suddenly occurs due to an unknown key-combination that I have executed and still can’t figure out. I end up going into Windows Settings, and sure enough, my keyboard has been changed to French, and I need to revert it back to English, sometimes needing to switch back and forth a couple times before it “takes”.

You might want to try the correct driver for your printer, just in case.

just double checked the driver, it is for TM-L90 it just looks almost identical to the other one lol

just checked laptop and pc and languages are set to English UK

The Epson printers usually come with some type of Utility in addition to the Driver. Within that Utility, you might find some character set parameters. Sorry, I’m not on my POS machine, so I don’t have the driver or utility installed here on my laptop to take a look.

Can you make a Notepad document containing the £ character and print it to the Receipt printer? Does it show correctly there? If not, then this is not a SambaPOS issue. If so, it is a SambaPOS issue.

When i try to type £ in notepad (shift and number 3) it displays # instead of £

Any ideas whats causing that? I cant even get as far as trying to print it as it doesnt show correctly on screen

EDIT: just did left alt+shift to change language (although language still shows as UK English the £ is now typing in notepad) ill try a print then try through samba

EDIT 2 - Notepad prints the £, i went back into samba and samba still doesnt print it and is still substituting it for ae

How is this set?

same as yours, unticked

Got me stumped.

Maybe open your Template and delete the character along with any leading or trailing spaces, then retype it?