Receipt order tag issues

When i add an item with an order tag, anything ordered below it is printed out with large spaces in between, and also it is printed with a lighter ink.

Please supply the following information:

  • Printer Make
  • Printer Model
  • SambaPOS Printer setup (Ticket, Text, COM, Raw, HTML)
  • SambaPOS Printer Template

Make: star
Model: tsp600
Setup: html
Printer template: i am away from the shop so unfortunatly cannot send the actual code in text format so the best i could do was to get my staff to snap a few pics for me. Thanks

lol. I really wondered what is the expected result when [ORDER TAGS] template section contains <L00> lines and <DB> (disable bold) command


What @emre is saying is you need to get rid of the empty <L00> tags and <DB> and <CUT> tags from your [ORDER TAGS] section.

It is printing spaces because you told it too. It is printing lighter ink because you told it too.

If your wanting space before the cut on each receipt then insert the blank tags and cut tag after {ORDERS} not after [ORDER TAGS]

Everything you put after a formatting section like [ORDER TAGS] it will format that particular item exactly how you define it. {ORDER TAGS} told it where to put everything included inside [ORDER TAGS]

So you basically told it to Print the blank lines and disable bold after every Order Tag. You then inserted the Order Tags after every Order.

Whats interesting though is why it didn’t cut after each tag lol. Maybe your printer didn’t recognize that tag.

1 Like

ok thank you for your help @kendash