Reports take forever to complete

Hi, after install a new SQL Server 2017 and SambaPOS on Windows 10. Checking the reports, I found out that Cost Report and others just showing Preparing Cost Report, and it took forever to complete.


I wonder if it is related to my SQL Server component which I picked when setup. I only chose to install Database Engine Services.

Have you ever faced this issue before?

what kind of period is set for dates?

It supposed to be the default Today report. It took unusual long to prepare a report probably around 20 minutes to 30 minutes, during such a long time, you won’t know if there’s anything wrong going on.

However, as long as the report showed, other reports worked smoothly until next work period (usually). The next morning, I have to wait for preparing reports again.

Does your device have an old HDD? Last time Ive seen this load time was on a 4 year old HDD.

Thanks for a feedback, sadly, it’s not. I’m on a supper fast NVMe SSD.

As I told you, after finish that preparing step, all the reports are as quick as it should be until the next day. When I told you 20 to 30 minutes, I tried to make the number as small as possible. It probably took me a whole morning to finish preparing.

Have you tried rebuilding indexes and safely auto sizing columns in Samba?

Hey, thanks! Your idea rings the bell, could you please show me how to do that properly?

Settings > Program Settings > Maintenance

1 Like

Cool, thank you so much. I will give it a go tonight and get back for the result tomorrow. Getting my hope up!

Is it the default work period report? How big of a database do you have.

It’s great, after do Rebuid Indexes, the reports showed up instantly. Thank you KryptonFactor. Also, Jesse, my database is around 500 MB now.


So sorry for the misinformation about database size ealier. 500 MB meant to be the database bakup size. The real size is 40 GB now when I check directly with SQL Server Management Studio.

No 500mb is correct. I’m glad you resolved it.

1 Like