Required .NET framework Version for Samba V5?

First Question:
Does Samba V5 require .NET framework 4.5 or can it work with newer versions like .NET 4.8?

Second Question:

If Samba V5 just works with .NET 4.5, can this framework be installed in Windows 10 or does it have to be Windows 7 or Windows 8?

.NET 3.5 for SQL Server
.NET 4.8 for SambaPOS

Yes it can be installed on Windows 10 but usually comes updated with Windows Update. So on a fresh Win10 install, let it update.

Is .NET 3.5 necessary for MICROSOFT SQL EXPRESS 2019 (Multiple devices) or is just necessary for SQL LOCAL DB? I don’t know if for SQL SERVER you mean SQL EXPRESS OR SQL LOCAL. (Not sure if it’s necessary for both of them either) Thank you!

I think 3.5 is needed for some backwards compatibility, not 100% sure but I use it for SQL Server 2014. You will need SQL Server 2014, 2017 or 2019 if you want to host database for multiple devices.

There really is no reason to install older versions of sql server on a windows 10 machine. Sql server 2014 will not support json for example and we need json for some usa specific reports. You don’t need to worry about .Net if your using windows 10 it will have all you need.

Older Local DB versions are there because we still have some users that use windows 7 even though Microsoft stopped all support for it.

Remember localdb is only for single terminal installs. If you plan to use mobile app or online ordering integration you should install full sql express latest version.

All of them are SQL Express, the versions are:

SQL Server Express edition
SQL Server Express Local Database edition

The primary difference is localdb runs only when sambapos is running. The full version runs as a service as long as the machine is on.