[Resolved] Automation Command Toggle Feature - Not Working

Im having an issue, i want the button to toggle between 2 things, however when setup and i press the button samba gets the “not responding” message and i have to completely close and reopen.

ive tried the setup im doing on the sample database and it works fine so i copied the rules and actions into my database but they dont toggle, they just send samba into “not responding”. i have also deleted and manually recreated but i have the same error, i know the setup works fine as it has on the sample data

any ideas what might be stopping the toggle feature from working and sending samba into “not responding”?

Can you show the screenshots? Or explain more of what your doing?

so when i press the “Open Bar Tab Button” this happens

Remember when you had similar issue involving states and now involving changing ticket type…

You should use two buttons and filter with state.

basically converting my bar tab setup with using the ticket tag function instead

ive just tried setting up a test button, no rules or actions attached just a button called test, the two toggle values are Test ON and Test OFF this gives the same issue, so i know it has nothing to do with any rules or actions

just a simple button that does nothing than toggle between the two values does not work

that last issue i dont think that was the cause as the toggle feature doesnt work at all, even when its just a button with no rules or actions attached

Hmm something else is the problem then they toggle just fine for me.

i tested the whole setup with rules and actions on the sample database and it worked perfect, theres something wrong with my database but i dont know what

for it to happen when its just a button there must be something deeper causing it

PM me a copy ill take a look.

EDIT: Lol it indeed does crash. I am looking into it.

You have a blank automation command in there I am testing it now.

EDIT: still looking

cheers thanks a lot :slight_smile:

Ok I found it but am having to narrow it down… One of your Automation Command Executed rules is causing it. I gotta find which one.

Holy crap thats a beast of a command lol

1 Like

haha i know lol

thanks again :slight_smile:

Ok its one of the discounts

bleedin discounts!!!

This rule is culpret.

I am now trying to figure out why.

Ok I can not explain why but your custom constraint


is wrong it should be


This was causing the problem. Why it would even trigger that I have no clue lol but that fixed it.

1 Like

thanks a lot @kendash :slight_smile:

@Jesse Less constraint always forces both sides to convert to a numeric value so whatever you type there non-numeric values will always become 0. 0 Less than 1 so it executes.