[Resolved] Restoring Database from one computer to another using database Backup tool

Has anyone come across below error message? when trying to restore the backup database file to another computer using the The Database Backup Tools module?

The master computer (Backup file created in) and second computer (New Computer) is configured with same version of SQL Server 2012 and SAMBABAPOS version 4.1.37.

All the the settings are identical.

The error is self explanatory. The user does not have permission.

Not sure what you mean by “The error is self explanatory. The user does not have permission.”. Basically, the restore feature did not work. i have tried to restore original " NABAB_20150xxxxx" compressed (zipped) file (as shown in below screen capture)

I have now used following manual workaround and mange to restore the database into SQL Server Management Studio of new computer successfully. Below are the steps

i then re-installed Sambapos as it was displaying message database version is not same.

Restored database is working on new computer!!!

It means the user you were logged in as did not have permission to access the database. More than likely the backup was in a folder that was restricted typically people make the mistake of having them inside a c:/user folder.

When you moved the file you put it into a dir that it had access too.

The restore feature is bound by the same rules as MSSMS but by moving the file you were able to give it permission.

Permission issues is a common thing people run into when trying to move backups from pc to pc. Sometimes they get transferred as read only… sometimes you need to ensure permissions are the same because your now dealing with a new user vs the other computer.

1 Like

Original database files was backed up under C:\Utils\MM directory and not under user accounts/folder. no permission was added to that folder.

We don’t want to get into semantics here do we?

Basically, the restore feature does work, but the OS prevented restoration to a permission-locked location. This is not a SambaPOS Issue.

@Jesse is absolutely correct. The file needs to be in a location that is accessible. In fact, I would not be surprised if SamaPOS simply uses the utilities provided by SQL Express to perform it’s functions.

1 Like

Thanks you guys. its working now. i’m still puzzled why it did not work initially. i have moved the database file under C:\MM folder and it worked.

Below was my original settings:


Both dirictoroes have Read-only

Good to hear you got it working.

If the path is read-only, how are you supposed to be able to restore to it? Restoration is a write operation :wink:

BTW that is not a true read only setting. Windows does some funky things since windows 7. Its mostly UAC related stuff.

To find out the true permissions right click it choose properties and go over to security and look at the user permissions.

You will notice some will have modify ability… some will not… if you choose c:/users for example and look at the permissions it will show read and execute, list, read only.

Now this might blow your mind but you might find that some files and folders ownership is microsoft and not you lol. They did this to prevent the users from destroying their computer on accident like you used to do with windows 95 or 98 by deleting files you did not mean to delete.

Advanced users can change this ownership and take full control of those files again but its not recommended because they are typically files and directories that can make your computer not work if your not sure what your doing.


The test system had fresh installation of Windows 7 professional with only one user account (administrator) with no password set. no other settings changed or configured.

Administrator cant even edit or modify files owned by microsoft… nor can the admin make changes to directories like users dir. This sounds odd but it was a good thing.

Now admin can manually take ownership and then modify this stuff because well its an admin… but by default its setup so it cant… too many people would login as admin on windows machines in the past and delete or modify stuff they were not suposed too and it would cripple the system.

pop :stuck_out_tongue_winking_eye:

Anyone else hear that whistling sound?

It was pretty controversial and the very reason windows vista got a bad name. It was introduced in vista. Obviously they were a little strict with it at beginning lol. I cant blame them… can you imagine all the technical support and mess they had to deal with on a constant basis because people would delete, move or alter files they should never have had access too?

Basically everyone wants to run as administrator… its the power account… but really you shouldnt…however instead of beating that dead horse over and over microsoft said ok use administrator if you wish but we are still going to do something to prevent you from destroying your computer.

1 Like

Windows 98SE was ultimate hackers OS. It was wild what you could do with that OS, likely because of the very reasons you mention.


Anyone remembers Windows for work-group 3.11? :slight_smile:

1 Like

Yes but I used command line for almost everything… i hated the windows back then. I always got frustrated and just went back to DOS interface. I used windows gui for the simple things though.


I remember win3, but my first PC ran Win95 on a Pentium 100.

Before that, my computer was an Amiga 3000 (32-bit), which kicked the ass off of PC/IBM in the day (16-bit), in both hardware and software. Going to the PC was like a downgrade.

Prior to that, it was an Apple IIc !

1 Like

I had a lovely Packard Bell with a Pentium 100… i saved the cpu chip why I dont know but I still have my pentium 100 chip lol.
Looked a lot like this lol:

I do not remember the brand of my first pc… probably IBM it had a 5.25 floppy which was external connected via serial. I was young and mostly played roger rabbit and leisure suit Larry on it lol.


wow!!! nice… as they say old is gold. :joy: does Sambapos work? :smile:

1 Like

Haha considering .net framework 1.0 released in 2002 i highly doubt it :stuck_out_tongue: