Restore database error

I’m trying to restore a backup I made yesterday (same SambaPOS version), and after clicking “Restore Database”, I get this error:

@pipo your sql server instance requires backup files should also contains log files. Did you intentionally put it into full recovery mode?

I’m not sure… I had to make some changes before to the backup/restore options because I was getting errors while backing up (or restoring I don’t remember).

Here’s my backup options in Management Studio:

And the restore options:

What should I change here?

OK. As always create a backup with management studio to ensure our data is safe :slight_smile:

Enable this setting for Backup Module and click Save.

Try restoring it again…

I tried that, and now I’m getting this:

SambaPOS_old database uses SambaPOS4.mdf files so it can’t restore. Did you manually renamed databases?

Try this…

  1. Create a new blank database with management studio.
  2. Extract backup zip somewhere and restore extracted bak file with management studio on that new database. You should also enable Overwrite the existing database (WITH REPLACE) setting on Restore Options. I hope management studio can better handle that case.
  3. If it restores fine update your SambaPOS connection string to new database name and continue using it.

Not sure if it’s the same, but I just deleted the SambaPOS_old database instead (I don’t need it anymore), and then tried again.
I restored the backup from the zip with Management Studio, this worked without a problem.
But now I still can’t use the backup module in SambaPOS. I’m still getting the same error, with the ‘Allow overwriting database files’ setting enabled:

Are you trying to restore old backup or did you created a new backup?

I created a new backup in SambaPOS and then restored it with the setting enabled, and then I got this error.

Weird… are you clicking Save button after enabling allow replace?

by the way what is the SambaPOS version?

Yes, it’s saved.
I’m using SambaPOS V4.1.55.

I’ve released some improvements with 4.1.61. I think that will solve this issue too.

I just upgraded to 4.1.67, but the problem persists.

I’ve reproduced it in my side and when overwrite setting is enabled it just restores fine.
When it started doing it? Did you successfully restored backups before?

No, I had only created backups with the backup module before, but not restored anything.

I don’t know if this is the problem, but when trying to change the database name in the connection string under Local Settings, SambaPOS does not save the database name. I keep changing it (and saving), but every time I go back to local settings, it is gone again.

after exiting sambapos and opening again, it’s back to this:

OK. Change SambaPOS4 Database recovery model to Simple by executing this SQL with management studio.


Can you try saving other settings? For example can you try changing terminal name or message server name? If they don’t gets saved too probably you’re having a permission issue.

  1. Click Display User Path and be sure there is no Settings.txt file there. If there is, backup it somewhere and rename or delete it.
  2. Click Display App Path and be sure your account have permissions to access Settings.txt file.

Thanks a lot, it’s working now!

which contained are backup in sambapos and if i change the system so backup is only database ya all over system

Sorry, are you asking what is backed up?
The database is backed up which is virtually everything other that the local settings.

Hi Trying to restore database from one system to new system for testing purposes. Do I need to upgrade sql server? or is this SambaPos issue.