Restoring Database from Newer Database Server Version Build to Older Database Version Build


I am trying to restore a backup database from the newer database server version build to an older database server version build. I do not know how to change or update the database engine to the newer version yet, is there anyway to update the engine?

BTW, the backup was from a 64-bit computer and I am trying to restore it to a 32-bit computer.

You cant restore a newer database onto an older version of samba. What you need to do is download the version of samba that that backup was used in and the restore it to that version for it to work

You can then download the latest version of samba and it will upgrade that database

I am currently using SambaPOS V5 (SambaPOS 5.1.60) on both computers, should I restore that backup again?

Depends what version you were using on the backup you want to restore

If the database was using 5.1.46 for example, youll need to download that version, then restore that backup, then download latest version so database updates

You need to find out which samba version you used to make that database backup. You might need to download them one at a time and try restoring your database until you find the version that works

I see, so even though I am using the same SambaPOS version for both, the database version would not be necessarily the same right? I see let me try doing as what you said then.

I have tried using this method before, the problem is the 32-bit is not compatible with SQL 2016… I am now currently trying to restore the backup to each SambaPOS V5 using the 64-bit computer and see if I can get it to work on the 32-bit computer.

So I have tried your method of trying each sambaPOS version, it doesn’t seem to work for other SambaPOS versions besides the latest version which is SambaPOS 5.1.60

Your issue is the 32bit version.

Looking at the version numbers they look like sql versions not samba versions… not sure if sql db version is 32/64 specific but are you sure you are using same sql instance/version i.e. 2012, 2014, 2016?

The SQL Version I used on the 64-bit is 2016 or build 13.0.1601
The SQL Version I used on the 32-bit is 2014 or build 12.0.2000

I already knew that this is the problem, so may I ask a method or a procedure to maybe create an empty database and paste it there? Or maybe could I generate a script from it? If so, can you tell me how to do it?

Thank you very much for your answers. I would greatly appreciate a solution to this problem of restoring database.

SQL Version 2016 or build 13.0.1601 does not support a 32-bit Processor, this is the reason why I ask a method or procedure to generate a script or empty database and pasting it there as a suggestion for solution… But I do not know how.

Google would be a better place to look, this is most likly well beyond 99.9% of the forum users knowledge…

First hit on google; last post offers a possible solution but not sure on what its suggesting;

1 Like