Restricting over charge on samba card

Continuing the discussion from Prevent SambaCard overcharging:

I have made the changes according to the above post. but still i am able to spent more then the balance in my card.

Is there anything else do i need to do?

Depends on your method, you can set limit on payment type selectors using payment processors but depends on how your processing the payment.

Thanks for your response.

I have followed and implemented the Sambacard.

I am not getting this terminologies like payment type selectors and payment processors. Is there any tutorial to understand this?

Payment type selector is probably a bad term as thinking about it its calculation which have selectors.

In payment types (in ticket options) the second option on the list is payment processor.
These are like constraints for payment types and limit/max shows a (£xx.xx) value inter the type on the button setting the max amoun

Add limit for example then gives you max, min, ask admin (pin to overide i think) and include previous payments (on that ticket).
You can use template tags or report tags etc to calculate these values.

I don’t want to set any min max value.
In any case i don’t want to allow customers from spending more then the amount in his/her card.

… that is setting a max amount!!!
The max amount payable by the samba card account is the balance!!!

Can you please tell me after implementing the following tutorial step by step

what exactly i need to do for achieving this result?

@Ankit navigate to Manage > Accounts > Account Types and for your Sambacard Account Type set the Rules section to the type of account your using. So for your case it would be Debit if you require money on the account first.

1 Like

I have tried exactly the smae thing with both the rules credit and debit but it is allowing the customer to over spent.

Hmm it should work let me test it.

EDIT: I just tested it and it works… Can you show some screenshots of your setup you must have setup something wrong. Show your Account Type for SambaCard.

Ok I know what is wrong one minute.

I am having the same issue when I use the new Fast Customer Account payment button. BTW the Customer Account Button in the settle screen is still not active if there is not enough money in the account to cover payment.

I think i know whats going on with the sambacard limits. The customer fast cash issue is different and you need to setup automation to set your limit. I had to go to some meetings so i wont be able to provide ideas to fix your problems until later today.

Hi. Thanks for your reply. I have checked it once again every thing is as per tutorial. I am using Pay By Samba Card option on payment page to process the payment.

Hummm - my Account were set to CREDIT and it works for me.

Hi pauln I have tried all the options Default , Credit and Debit and it is not working. probably i have made some mistake some where else let me check once again.

Ok - if you have it correct, when you move to Settle Screen and select “ALL” (or type amount in) the Accounts you can you will be highlighted. The Customer Account will only highlight as you said if the transaction amount is not over it Account Type OR you have used some sort of Credit Limit.

I have not checked the Tutorial Lately so not sure how it has been setup.

I hope you noted kendash’s comment Fast Payment Buttons need to have “automation control” to restrict limit.

It has to do with the setup of the payment transaction for sambacard. Im still looking at it.

@Jesse fyi: I recently fixed expression support on add limit payment processor. See this one if it is something related with what you’ll look at.

1 Like

That works thanks. Hopefully the others see it.