Round Calculation Issues

@emre, I am having issues getting the Round calculation to work automatically.
I have removed the button header from Round Calculation Selectors, and auto rounding is working - kind of.

But, we round to the nearest 0.05 and SambaPOS is only rounding to a maximum of 0.02, and I cannot make it round down either.

If I add one item at $2.98, it shows
Ticket Total -> 2.98
Round -> 0.02
Balance -> 3.00

If I add two items at $2.98, it shows
Balance -> 5.96

1 Like

Hello John. This is how I configure auto rounding and it seems working fine for me.

fyi. this is a DatabaseTools export. Please install at least 4.1.26 to be able to import calculations. (700 Bytes)

I didn’t have the Round Down as well - now working ok.
But only having Round Up, why would $5.96 not be rounded up if I am rounding to 0.05 ?

Maybe you’ve enabled Toggle Calculation setting. When enabled it removes calculation from ticket if calculation amount is 0 so further recalculations does not appears.

Nope. So I just removed Round Down from the calculation selector so only Auto Round Up is active.
If I have 2 items @ $2.98 the total is $5.96 - no rounding to $6.00.

With Round Down in the calculation selector, it will round down to $5.95.
Sometimes we will only Round Up or Round Down, not both. And general retail practice here is to round down.

OK. I see. Since 5.95 is nearer it skips. Maybe I can add more calculation types to always force it to round up or down.

1 Like

I’ve impemented Round Ticket Total Exactly calculation. If you enable Decrease Amount that always Rounds down. If not it Rounds up.

1 Like

Hi @emre and @JohnS

I need to make use of this great feature as well, mainly when customer present a discount voucher i.e 20% OFF. Sometimes we end up with this:

We don’t use pence, our minimum is 0.05 Pence. So Ideally I would need to round down to £4.75.

I experimented in training mode the but this was rounding a perfectly fine 5.95 to 6.00, see:

Is it possible only to round when necessary?

Okay solved.

Had to change the calculation types rate amount to 0.05.


1 Like

It seems you found a different way to use Training Mode. Very nice :slight_smile:

Training Mode, is a amazing feature. If I’m doing any changes to rules or experimenting I do it in training mode 1st :slight_smile:

1 Like

Hi @emre, i was testing the Auto round calculation rule with and come across following issue when applying Discount.

Below are my settings

Auto Round Up: rate set to 0.05

Auto Round Down: Rate set to 0.05

if i add 1% discount it does not calculate Auto round figures as expected. same for 4%,6% and 9 % as per below table.

Did you accidentally disabled Decrease Amount setting for Auto Round Down calculation?

no, i have also tested with Enabling Decrease Amount setting for Auto Round Down calculation. it did not make any difference. With Decrease Amount enabled, it should have decreased the figure, which did not happen.

How did you configured Calculation selectors ? Are you using Import file?

i used the import file option ( (700 Bytes))

So how calculation selectors configured? Does it contains both calculations (Up and Down)?

yes, it contains both calculations.

@morshed1 please double check Decrease Amount setting enabled for Auto Round Down calculation and Log off / Log in to clear possible caches. I’ve imported it to a clean database and seems working fine.


Are you doing this on a open ticket that you had on your system before you implemented the rounding feature?

Try creating a new ticket and then test how the rounding works. I don’t think it works on tickets that were created before you implemented the rounding feature, I had a similar issue.

1 Like