Samba infrastructure settings localsettings error

Hi @emre,

Could you check this message error? It throw it when I try to open SambaPos, I didn’t make any change

I tried to restore database from the SQL Management and tried to reinstall SambaPos without success

I restored the database on another computer and it works, but the computer I am working on , it doesn’t.

Tried to deleted the database and make full restore without exit

If you click detailed report can you paste it in here?
What version of SambaPOS4 ?

That problem is write problem at SambaSettings.txt .

Step 1: BackUp your data.
Step 2: Delete or rename sambasettings.txt (inc. C:\ProgramData\SAMBAPOS\SambaPOS4)
Step 3: Uninstall SambaPOS
Step 4: Install SambaPOS


@Jesse, i’m used the last version published today.

@mehmet, thank you, I deleted everything except that folder (step 2)

Now everything works fine, thanks a lot to both, very appreciate it.


1 Like

I have the same problem and cannot get rid of the exeption.
I am running POS4, latest version on Windows 8

All was running fine and then today I get the exeption.
I have followed these steps… How do I backup my data - menus, products entitied etc?

Please can you help? @mehmet

if you are using SQL Compact Edition (SQL CE) you simply just have to copy the SambaPOS4.sdf file from My Documents\SambaPOS4 folder. but
if you are using SQL Express Edition you can do a backup in SQL Server Management Studio.

@mehmet Thanks, its still not working. I don’t have a .sdf file in My Documents.
I cant get rid of the exception error. Any more ideas?


Were you running SQLEXPRESS?

Technically it would be C:\Users\USERNAME\Documents\SambaPOS4\SambaPOS4.sdf

You would replace USERNAME with the user installed it under.

If you were using SQLEXPRESS you would need to use Management Studio as @mehmet mentioned.

EDIT: If you already followed those steps and have not backed up yet… its likely you deleted the .sdf file already.

EDIT: If you have not followed all of the steps yet you will need to delete or rename SambaSettings.txt like he mentioned but to see C:\ProgramData it is hidden you have to enable viewing hidden items.

Thanks. It was a hidden file.

Now my only issue is that my Table (entity screen) is now empty.
If I go to custome screen and search I see my tables but they are missing from my main screen?


It probably needs to be linked to Customers Entity again.

Hello i’m having this same issue and i cant seem to find the SambaSettings.txt any where i have enable the hiddens files and nothing this is something very weird last night everything was working perfect this morning looks like power went out last night i turn on the PC and i’m getting this error not sure whats going on but have no idea on what to do to fix this and not lose all the information i have such as customers products everything. help…
Using SambaPOS4

Can you add a screen shot of C:\ProgramData\SambaPOS\SambaPOS4 folder?

For next version I’ve created something to backup / restore settings.txt file. I hope that will solve some file corruption issues.


I’m having this problem on my server but I can’t find a “ProgramData” folder?? I’m running SQLEXPRESS and I’ve tried reinstalling samba but no fixee

that folder is hidden you have to enable hidden files to see it.

1 Like

Dear Emre,

How are you?

My computer restarted due to power failure and it started poping out this exception error.

Can you please assist the exact procedure i need to do get things corrected and working properly.



@napsterj, have you followed the advice posted earlier in this thread? In particular, Step 2.

Seems like your user account does not have permission to write to temp folder so it might be a permission issue. Can you also try running it as administrator?