Samba is extremly slow and laggy on my first deployed machine

Just went to deploy samba on a register and it seems really laggy if I can say that. this is what it looks like on the deployed computer

It’s nowhere near the speed I was hoping for and was used to any suggestions/things you would like to see?

It shouldn’t be that slow. It’s virtually instant on a low spec all in one ive been testing. Can you share the setup? Is it connected to database or is the dB on that actual machine?

Im aware it shouldnt be that slow and the register isnt at all low spec. 4gb of ram i5 process fresh install. I dont know why its so bad

Ok, the db is in the actual machine its a SQL 2014 Express db.

It definitely looks like it’s slow when accessing the dB but instant when it’s accessing local settings etc. So we need to narrow down why SQL would have that delay.

Would you like me to record any other actions? Or do any tests on the db? I’m really incompeenet with sql servers and things like that, so sorry :wink:

I tried to get a report on the db, i have no idea what im doing

Need to run some queries and test performance. Look on forum for some tools I know @emre had posted some in past.

Pm me a backup I can test if it’s your configuration.

Heres what it looks like when im running it from a text file

mmmm, what other software are you running on the pc?

are you using edge or explorer and did not close it on a long period of time? both do consume memory and do not release it… i had that problem…

anivirus? one antivirus that uses a lot of resources is kaspersky, its great, but slows down machines like hell


Antivirus is Sophos, besides that its a fresh image however there proabbly is a lot of crap

As oyu can see from the above gif when im running it from a .txt file its really fast and crisp

Text file doesn’t do any calculations or expressions nor advanced queries or writes so it’s not a fair comparison but your SQL should be just as fast. We will figure it out.

It was mainly a check to see if there were programs causing it to slow down

1 Like

That’s also not likely a correct method to test that.

Hahhahaha, I guess so. I just want to get this wokred out, and am triyng as much as I can think of

I got your backup but its not the correct kind of file. How did you create that backup? The actual file is unkown type… it should be a .bak file.

Just change the extension to .bak it should work then I think, I used that exact file to create the db on my deployed machine

Did that work or would you like me to create a new backup?

That worked. I am looking at it.

Pretty sure its your customer display causing the delay. I noticed the delay right away specifically when it updated display.

Edit: My system is a beast so it wasnt as noticable but I still saw it. I run very fast ssd’s and as a result it handles that faster.

Cool :slight_smile: theres a lot of things in there which I probably don’t need, and are left over from testing.