Samba New Mobile Client issue

Hey guys its been a while since ive posted anything or tested anything. Biggest reasons due to relocating to a different state and a whole lot happening.

Finally got around to testing the new mobile app.

Ive followed every step in the knowledge base to get this client to work. I get as far as logging in successfully but after login it just stays stuck on a white screen whilst at the bottom saying connecting.

I know message server is working fine becausr ita able to connect and login, the helper is also running fine. I have cleared the license keys also and reactivated.

Cant figure out where im going wrong.
Any ideas?

You setup the application correctly in sambapos? And you have installed the helper service? The client works im testing it now. You have latest version 2.0.13? The app setup in Sambapos changed too so check that.

App setup should look like this:


Should have a user called pda with a password of 2122520634


BTW it does seem like a visual bug mine too says connecting even after its connected and working. So it seems you have a configuration issue. Is your tables entity screen setup?

Here is a shot of mine showing the connecting visual bug.

Mine matches that correctly.

Also got this set as per the instruction manual.

here is the Entity Type

Entity Screen

Tables on POS

Here are the settings on the android app

After clicking on save did you run the updater?

Yep. it updates ok. Just doesnt want to show up. I removed cache and data from android app and re tried again but still no luck

Hmm odd. You have latest version 2.0.13 and latest version of the updater on server? Message server was setup on port 9000+ ?

Yep. downloaded the latest version of the app. got the latest version of sambapos and Message server is on Port 9000+ too. It’s quite odd. Can’t quite put my finger on it.

Also how can I get the helper to work whilst firewall is on? IS there a particular port or app I have to make an exception for? right now firewall is off and its the only way I can get the app to even respond