SAMBA POS5 becoming unregistered and unlicensed daily

I have been using SAMBA POS5 with a paid licence for about 3 years now and over the last 2 months we have had to clear and re-register our license key on a daily basis as we continually are getting a message that the product is unlicensed.

Through the SambaPOS Community portal I can see that we have a license and I do have the option to clear then we re-register on the terminal.

We are only running the POS on a single terminal and have not made any network or software changes to the terminal on over a year

what can be causing this as this is extremely annoying and the message continually pops up on very busy nights causing issues with the cashing out etc.

is it possible that this licence has been accidentally sold to another user and now are showing as being used on multiple machines?

Please help because this is making the software unusable and we have had this licence since 2016-03-23

What version are you using? And are you automating any backups ?

The latest versions seem to have fixed this for most people. It can still happen if you run frequent backups multiple times a day.

Very unlikely if not impossible.

Licenses are assigned to an email. As far as I am aware from my resellers interface you cant assign same email twice.

Do you have any automatic backups based on triggers?

Have you tried deleting the licences on the server and reinstalling it?

Please login to your account on
You can see your licence(s) in there.
If you got still problem we can look your account but it is impossible to sold another user.

Sambapos licensing is done via email, most likely you are using the same email to activate two databases/ establishments. If thats the case, you will have to procure an extra license for the second establishment.

I had this issue with 5.2.16 a lot!
In fact in my case SambaPOS did not become really unregistred, but this message always appeared on client hosts when the server made a Database Backup.
What worked for me: simply restart SambaPOS on the client computers. After this the message is not there anymore.
Try restart SambaPOS without doing anything and see if the message is still there?

It sounds like you had same issue and solution as me. It seems if backups are being done with triggers something makes it do that, in fact it creates a little red label where “Unregistered trial” usually is.

Try using SQL Backup Scheduler instead of built in Database backup functionality. Its pretty simple to use.

It used to be an issue in older versions. Latest versions only have it if you do very frequent backups.

1 Like

Built in database tools works great but not for constant backups multiple times an hour

1 Like

Hey! I just love pushing things past the red line :smile:

Which version SambaPOS do you use?
And do you use AutoBackup?

Hi guys, sorry for the delay in replying.

Our version is 5.1.62. We have been using V5 since 2016 and this just started happening just about 3 weeks ago. I have checked the license at and everything seems fine here.

I will check the issue with the backups as we do use samba to do these but again, this has not changed in 3 years.

There seems to be some other issues here

Can you please update the version. 5.1.62 is very old. I think after upgrading you cant see that problem

Yes like I said most of those issues resolved with version updates.

Okay guys, I will do the update this afternoon and let you know

thanks for the help

I downloaded the new version and installed but now it is stuck on the loading screen and will not pass.

I have rebooted, reinstalled, checked the samba settings file for database reference and these does not seem to be anything wrong

what could this be now?

I am not getting any errors or messages

Please remove SambaPOS firstly. (Backup your settings file)
And control program files and documents SambaPOS directory. If still there you can delete it manually.
After this install new version and replace settings file for a clean installation.

If you are updating in a big jump like that and have a large database it can take longer than usual I find. presumeably due to changes in the dstabase. I