Samba V5.2.22 Loses Registration

We keep having problems with samba losing its license. Sometimes it happens after running an update (windows or to samba) but sometimes it will not lose the license until 2 or 3 days after running an update.

Sometimes it loses activation for no known reason (we never ran any updates or anything).

We can always login and clear the keys and go through all that but sometimes It is a real issue because I am not near a computer to walk my employees through the process.

Why would it keep losing the license activation? In two years it has happened 8-9 times and sometimes our system is non functional for 2 days at a time depending on where I am.

This was fixed in a recent update, you’re not using the most up to date version of samba

Please update and let us know if that sorts it

1 Like

Ok, I will do the update and see what happens. I will keep you updated. Thanks for the time RickH!


Ok, now bigger problems.
So yesterday i changed the password on cp.samba… whatever because now I am thinking my employees need to use my login when i am not around to clear the keys and fix the non working Samba.
Today I upgraded the system with 5.2.24 and (from another computer) logged in to the site (with my new password) and cleared the keys. New system will not allow any login (either old or new password) and is unregistered and I cant change it after messing with it for more than an hour.
What should I do now? Nothing I know works and either or my passwords work on the actual running POS system.

So if you changed the password for your license you should go to Samba Market on the POS and click once on your email in the top right corner.

Then login with new credentials, exit the POS, open the POS and press Activate. This is how I usually do it if the internet speed is slow.

If both your PINs and passwords dont work is there a chance SambaPOS is not connected to your database?

So after messing with it forever last night, i rebooted the computer and tried again in the morning and it worked. I ended up rebooting the system again after getting it licensed and functioning.

It was connected to the database last night but for some reason it just wouldn’t accept the login credentials. Thanks for your help and we will see if this fixes our licensing issues.

If you have further issues let me know I can connect via Anydesk and try to help you. IF you are doing regular backups it is recommended to only backup once a day if you need more frequent backups use Microsoft SQL Server Management Studio to perform scheduled backups and not SambaPOS Backup Module. Doing rapid backups with the sambapos database backup module throughout the day can sometimes mess with the license.

Thanks Jesse. I have never messed with adding any backups. I only see it making one backup at the end of the day when we end the work period and it automatically does a backup. Thanks again for the reply and all day yesterday things were smooth without an issue regarding the license. Within the next few months we will see if it fixes our problem. Thanks.