SAMBAPOS 4.1.17 to 4.1.18 in SQL mode problem

Dear @emre, I have installed and run 4.1.17 with SQL and when Iinstalled 4.1.18 The program says “Database Version” and cannot enter pin… nor enter into samba…

Could you help me out here please!!!



Did you fix this?
If not try reinstalling 4.1.18 on both computers

tried to install in both computers, both computers same message
seems like as samba has new colums in tables, for some reason… sql is not adding them…

trying to fix it manually in sql, but with little or no knowlege is hard…


I just upgraded to 4.1.18 with no issues.
Did you change database after installing the new version?
This happens if one computer has been updated and not the other, or you restored/changed to a database for an older version of SambaPOS.

Reinstalling SambaPOS will fix the problem.

Please don’t change any SQL data directly. There is no need.

I installed 4.1.18 in both…

But what happens if i install 4.1.18 in one, run it and then install in both?



I try to run 4.1.18 with sql database created in 4.1.17 and the message “Check Database Version” appears…


@gerlandog SambaPOS needs to update database when you install a new version. If you switch your database that you’ve used with an earlier version you need to reinstall SambaPOS to start migration process. Just reinstall 4.1.18 and let it update your SQL database.

Thanks @Emre, thats what I did twice…
no luck here…

will try a third time… as the saying, third time charm…



When you install a new version, nothing happens to the Database until you run SambaPOS. The first time a new version is run, it will update the database.

If you get a check database version error, reinstall SambaPOS and run SambaPOS to update the database. If you change databases to an older version, you need to reinstall SambaPOS to trigger it to update the database the first time you run SambaPOS.

THIRD time, CHARM time… jajajajjajajajajjaja
THANKS TO @emre and @JohnS, I do not know what in hell I was doing wrong, but for sure something was,since I installed and it worked!!!


I will try now in the other computer!!! lets see what happens… but with my luck… jajajajajjajajajajajaja