SambaPOS 5.3.6 Release

but we are marking single orders as finished, not a whole ticket. I guess that by passing ticket id, the print task would not know which specific order from that ticket should be printed, right?

1 Like

Are you facing the same problem?
Once the order is completed, the waiter screen shows blank?
it was working in V5.30. But after updating it doesn’t

Are you using addTask mutation? Another user has the same issue with this mutation.

1 Like

@sangeethrayaroth that is a custom screen with custom work flow. We would have to understand what you built in order to provide good advice

1 Like

Hi @jesse,
I used the import file posted by emre in a previous post. It was using task printers to implement waiter screen & the kds. You want to see the tasks i have created?
I installed the V5.30 version again. But cant login. It is showing check database version error. Can u guide some steps to login to that version again? Tried removing the samba settings file. But no luck.

I believe you’re facing the same problem as I did. addTask just does not work in 5.3.2 and newer versions.

To login with 5.3.0 you have to delete entries from VersionInfo table in your database via Microsoft SQL Server Management Studio by running this query:
DELETE FROM [your_database_name_goes_here].[dbo].[VersionInfo] WHERE Version > 153

Please note that this is for sure not recommended as you are using a database altered by a newer version of sambapos with an older version of the sw. I did not have any issues on my live setup, though.

I’ve found a workaround to make waiter screen working again without the addTask mutation - just use the add task action.

But I believe someone should look into it and fix it in the next version…


Thanks brother. Let me try this.

There have been changes made do the database schema itself - columns added, constraints, etc. Each build has its own set of models that mimic the database schema and may throw exceptions if data is returned in a query that doesn’t match the model. Not 100% sure as I’m not too familiar with EF yet.

Whilst you may not have experienced anything problematic right now there can be issues in the future.

Let me see if I can put together a downgrade script from 5.3.6 → 5.3.0.

yep, I can imagine that deleting the entries in VersionInfo is a nasty thing to do but I was hours from opening the restaurant and the waiter screen stopped working because of the update.

I have updated to 5.3.6 since then. Should I be worried about a corrupted database or should it be fine now? I went from 5.3.0 to 5.3.6, back to 5.3.0 after deleting VersionInfo and finally to 5.3.6. after the addTask workaround.

Thank you

1 Like

If you’re back on 5.3.6 then I wouldn’t worry as everything will be as it should.

It worked. Thanks brother

What if i am restoring with a backup file that created before the upgrade?

So long as the db version matches the running version of SambaPOS you’ll be fine. So if your backup is from 5.3.0 make sure you are running 5.3.0 as once SambaPOS starts it will automatically update the db if needed.

1 Like

Yes. My back up db version is 5.30.

Then be sure to uninstall 5.3.6 and then install 5.3.0. You can use stroodl’s way of deleting the version history and that’ll allow 5.3.0 to connect to the db and you can then restore the backup.

The other option is to just delete the db from within SSMS, run 5.3.0 and after it creates the default db, restore the backup.

1 Like

Sure. Thank you for the support. This fixed my issue :slight_smile:


Hi Guys, Wanting to update SambaPOS to the latest version. After reading through the thread, I wonder if the above issue is still relevant to 5.3.6?

I have a setup running the Default Kitchen Display setup via task printer, thanks.

Updated from 5.3.0 and now when I try to close a ticket it says ticket changed, your changes were not saved

Hello @Vasilios,

You can have a look at below topic for the same issue;

1 Like

Also got the this problem with 5.3.6 for Waiter Display setup via task editor, like @stroodl previously described. Will it get fixed on 5.3.7?

1 Like