Sambapos4 string problem

In Local disk c, programfiles(x86) there is Sambapos4 and the following samba files

Hope you can open this to see. I can not find the text file you stated.

@Bonamanzi, you need to access the C:\ProgramData\SambaPOS\SambaPOS4 folder.

step 1: Do a search for SAMBAPOS4

Step 2. Selct the C:\ProgramData\SambaPOS\SambaPOS4 folder

Step 3: Selcet SambaSettings.txt

You are fantastic! I’m in, Thank you. What now.

Please follow below steps as recommended by Emre.

2.Find SambaSettings.txt under that folder.
3.Double click on it to edit.
4.Find … tags.
5.Clear everything between these tags and type test.sdf between them.
6.Save the file and Restart SambaPOS.

Now SambaPOS will restart with a new local database. Delete all SambaPOS related Databases with management studio, correct your connection string and restart SambaPOS.

its should look like:

@morshed1: How do I delete the database? Do I delete everything in the management Studio? This is my first time, please give pointed instructions. Thank you for your help.

1 Like

Two way to delete the Database:

1: By Management studio

or by accessing the DATA base file from following folder.

In my example I have two Database files called, SambaPOS4 and test.
To remove the database file all I do remove the database file from below folder.

@emre How do I delete the old databases with the management studio? I have done the above 6 points. Do I press the ‘start client now’ button?

No start client now is something different. If you reached that point it seems you can start SambaPOS without problems. Now you are connecting to a local database. If you’ll use SambaPOS from a single computer you can continue using it but if you have multiple terminals you need to setup SambaPOS to access SQL Server.

Create a copy of SambaSettings.txt so when something goes wrong you can rollback to working settings.

Now do it carefully. Click […] button next to Connection String,

  • Data source : Type your SQL Server Instance name here. If you don’t know what is your SQL Server instance name check it from Management Studio as @Isaac suggested.
  • User id : Type your SQL Server User Name. You’ve configured it while installing your sql server. Most generally it is sa
  • Password: Type SQL Server Password here. You’ve also configured it while installing sql server.
  • Database: Type something uniuqe here. For example it can be Bonamanzi. That changes default database name so you won’t need to delete old database.

Save it and restart SambaPOS.

@emre, @Isaac, @morshed1- My server works great. Thank you. Do I set up the other computer in the server computer before I install the program on the other computers? Thank you for your patience and help, you guys are great.

on other computers just install sambapos then add the same Connection String used on on your server. you can follow below guide.

1 Like

It till says “message server not connected”.

its covered under:

Thank you @morshed1, I will do so in the morning( its evening here) and let you know, as I know that it will turn out perfectly. Good night.

Hallo @morshed1, the messaging service does not want to start.I have tried 8080 and 8383. Error message reads as follows:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.Net.Sockets.SocketException (0x80004005): Only one usage of each socket address (protocol/network address/port) is normally permitted
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at System.Net.Sockets.TcpListener.Start(Int32 backlog)
at System.Runtime.Remoting.Channels.ExclusiveTcpListener.Start(Boolean exclusiveAddressUse)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.StartListening(Object data)
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel.SetupChannel()
at System.Runtime.Remoting.Channels.Tcp.TcpServerChannel…ctor(IDictionary properties, IServerChannelSinkProvider sinkProvider, IAuthorizeRemotingConnection authorizeCallback)
at System.Runtime.Remoting.Channels.Tcp.TcpChannel…ctor(IDictionary properties, IClientChannelSinkProvider clientSinkProvider, IServerChannelSinkProvider serverSinkProvider)
at Samba.MessagingServer.frmMain.StartServer()
at Samba.MessagingServer.frmMain.button1_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

************** Loaded Assemblies **************
mscorlib
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll

Samba.MessagingServer
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/SambaPOS4/Samba.MessagingServer.exe

System.Windows.Forms
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll

System.Drawing
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll

System
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll

System.Configuration
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll

System.Xml
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll

Accessibility
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/Accessibility/v4.0_4.0.0.0__b03f5f7f11d50a3a/Accessibility.dll

System.Runtime.Remoting
Assembly Version: 4.0.0.0
Win32 Version: 4.0.30319.18408 built by: FX451RTMGREL
CodeBase: file:///C:/Windows/Microsoft.Net/assembly/GAC_MSIL/System.Runtime.Remoting/v4.0_4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

Samba.Infrastructure
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Program%20Files%20(x86)/SambaPOS4/Samba.Infrastructure.DLL

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

The error message says:

You need to install message server only on server and you should either use service or stand alone server. I think multiple instances of message server running.

@emre How do I stop the other services? An where?

You’ll use Samba.MessagingServerServiceTool.exe to start stop service.

as @morshed1 said you can find details here

I have done that, the error message is what I get. I have installed it only on my server computer and not on the others. The Sambapos program keeps showing the red message"Message server not Connected. I have first used 8080, when that didn’t work I used 8383. Still no connection. Inside Sambapos the message server port is set to 8080. Do I have to change it in both places?

you receive the error message because you have multiple samba message server running (you can identify this by the icon on the bottom right corner)… i believe the error message is similar to below… can you close the Samba Massager server.

Below is my settings: it should be something like below…

1 Like

@morshed1 Thank you, I will look at it in the morning and let you know if I still have problems.Have a great day/evening.