SambaPos5 synchronization


#1

Hello. There is a server based on Windows 2016 and 2 terminals based on windows 7. The problem in the absence of synchronization:

  1. Changes do not apply immediately to all terminals, we need to reboot.
  2. The working period should be closed on both terminals.

How can this be rectified?


#2

Are they definatly on same database?
Work periods should reflect on all terminals on that DB.
Some settings do require samba to be closed and opened again to be refreshed on other terminals, this is due to the fact that samba will cache some of the settings to reduce the need to query DB for every single thing.


#3

Of course, both terminals use one DB at the server (with MS SQL Express 2016). Ok, but a problem with work period - is a problem for us. How to fix it?


#4

Perhaps explain what your problem is? You just say period should be closed on both terminals…


#5

Is message server setup correctly and connected on all machines?


#6

For example: If you close the working period at terminal # 1, terminal 2 will still have a working period.

I did not know what to configure the message server. Is there a link to the manual?


#7

It’s on the forum where install instructions are. You install on one machine and make others link to it like DB.

That is not default or correct config so something is wrong somewhere.


#8

The problem is because you don’t have message server running


#9

I’d have to say I’m experiencing also similar issues with latest version of sambapos across 3 devices connected to a server.
Message server is configured correctly with the correct ports configured in firewall.

The issue I’m experiencing is that it works… Only sometimes… An example of this was when I was on the server machine, I added a new item and took a new order on a table and closed it.
2 other clients didn’t pick it up even though message server was running and it showed connected as well.

I think this has something to do with SQL connection idling… I had an idling issue when I was running wireless tablets where it took at least 5-10 seconds to reconnect to the SQL database before you could interact with any table or add any order then after it you could use it normal until you left it idle again.

Similar thing in this case however once i restarted sambapos to refresh cache, tried another update from main server and it still wouldn’t quite update on the other systems unless i restarted sambapos again.


#10

Do u use RDP in tablets?


#11

Nope. I used windows tablets with SambaPOS installed as clients.


#12

I think this seems a network problem.


#13

This Idling issue has always been there when using windows tablets over WiFi. The other cases I stated was using Ethernet based connections to a switch. Clients were not updating when server made changes.

The Idling is the SQL database idle setting. When the device reconnected to SQL database it works fine, but if you leave it for about 3-4 minutes, SQL loses active connection and have to wait sometimes up to 30 seconds before SQL connect again(This is network part). If there was a way to fix the SQL idle to always keep active, this would most likely solve 90% of my tablet problems.

But the other cases are not because of idle problem. It’s something else.


#14

Your tablets arent industrial tablets i think. So it can be close connection for battery saving.


#15

That is software based. I don’t think it makes a difference if the tablet is either industrial or not. I have tested with Dell tablets, rugged industrial tablets, chinese Chuwi tablets, HP tablets. The issue is the same.
When it’s connected to SQL it runs fine, you can take order over and over as long as there is no break in between.
If you leave tablet idle(Even if power saving is off) for a few minutes it closes the database connection.
I thought maybe it was battery saving but I changed battery savings to never lose connection and not go to sleep mode, so tablet is always active(Drain battery big time) but still, leave tablet for 2-3 minutes and SQL closes connection.

This issue is more related to SQL than SambaPOS though. What the initial post is about and the other issue i pointed out, they don’t relate to SQL specifically.


#16

I don’t think it would be SQL pushing updates to tablets though. Isn’t it message server with triggers updates to screens etc?
I can’t imagine samba is constantly querying database to check for updates without user interaction like going to entity screen queries open tickets etc.
Have you changed the network interface options on the tablets as well as the Windows power saving options? Most network cards I have seen generally have idle/power options of their own in driver/device options, especially wifi.


#17

The shop has 1 main server, and 2 client systems attached to a switched directly via ethernet.
Message server has been configured and setup correctly.
Each systems has the word “Connected” Which indicates the message server is working as it should be.

When taking orders, sometimes the shows on entity screen, sometimes it doesn’t. If I close WP on server for example, it doesn’t apply it straight away, you would have to log out of SambaPOS and re open it again.
Same this occurs when I tried to add a new item on the menu or a new function. Even though message server is running, It’s not automatically updating the other terminals.

On the tablets, I thought that was the issue as well where idle/power settings may be the culprit, however i changed the settings for idle/power to never go idle or go to sleep mode or shut down network activity or application activity during certain idle period of time.

For tablets, I even setup a rule which acts like a ping pong effect just to keep the connection to SQL active.
unfortunately that didn’t work too well either.

I’m looking at an application to which may help to keep the SQL connection active at all times, i’ll see how I go with that.


#18

Please provide screenshots of message server tab and database connection string.