Scale integration problem: Access to the port 'COM3' is denied

I have scale which is “MASSA-K MK-15.2-TH22” scale has a own driver and program
in scale program scale is working without problem but in sambapos it gives error Access to the port ‘COM3’ is denied

and then when i try on pos section it shows up weight 1 second and goes

can we solve the problem? thank you

Access denied usually suggests port is in use by another program.

Ive never used a scale device but imagine they are similar to barcode reader/msr etc they work like a quick keyboard and type the numerical value of the weight.
Try a search on how to setup.
My though might be to try the flow of…
Add the item.
Select the order on order list.
Have a button for weight which fires update order action with QTY as [?Weight] prompt which will give an input box ready for weight.
Then weight the item and the scales input the weight into the ?prompt field…

Just a thought… never used scales myself.

Sambapos supports scales natively without that kind of automation. There are some v3 tutorials that could still apply. I can’t look them up right now I’m on my phone.

1 Like

well i also thought first port is busy by driver but when i installed the scale first time weight is shows up 1 second then i thought close the driver and try without it and then nothing happens well lets see
this scale brand is bigest company of russia and other close countries if we figure it out i think it will help other people in the future too

You need to see what the scale is sending the computer. Have a look here at this tutorial, it gives details how you can see what is sent using using the Putty app. It could be the scale is only sending one time. Also important not to have any other driver or scale software trying to access scale at the same time - SambaPOS accesses directly from the COM port so no other software or driver should be needed.

I have only once tested scale with SambaPOS, and I did get it working but needed to customise as I was using a different brand scale.

No, scale sends the data directly to COM port, it doesn’t work similar like MSR or barcode scanner - it doesn’t send via an emulated keyboard. However as mentioned SambaPOS has support for scales built in.

I have tried that on putty nothing happens. when i close all the scale program sambapos is not giving that error, but it doesnt show anything on Sambapos but the important thing is weight is lighting up for 1 second, i also tried virtual serial port it is giving that error again. maybe we should look at coding of Sambapos why Sambapos is giving that error

this is the properties of scale so signal is coming to port

If you can’t see anything on COM3 with putty then you won’t see in SambaPOS also. Putty proves there is an issue with communicating with your scale. If the test software is giving you a result on COM3, it is likely that the test software is also blocking COM3 from any other software accessing it. So you need to ensure nothing is also accessing scale otherwise SambaPOS won’t be able to access it. I suggest you try to get data coming through Putty first then you can also confirm the data and format the scale is sending.

When it does come up, you have item on scale, then it disappears. What happens if you then change weight on scale (put other item on)? Does it come up for 1 second also? My limited knowledge of working with scale is that the scale keeps sending data to the COM port, and SambaPOS will display whatever it sends. I wonder is it possible that your scale is only sending data one time then sending empty (or non-numeric) data if the weight doesn’t change? Reason I think this is your test screenshot, shows “Warning: weight does not change”, I wonder if it is sending this data?

The error says access denied to COM3 - it is pretty self explanatory, it means the port can’t be accessed. This is why I mention about checking with Putty and you also can’t access from that.

1 Like

i tried to connect port directly Sambapos does not give any error but nothing is coming up. and on putty also nothing happen too
yes it comes up just 1 second first time when i put something on scale, when i put something different second time nothing comes up
yes putty, kitty nothing is working

So we now know it’s nothing to do with Sambapos. Maybe look through Google see if others have that issue with that scale.

1 Like

Also, check the baud rate is set correctly for COM3. When using serial connections, the baud rate must match on the scale (which you likely can’t change) and the PC. Like Kendash says, it isn’t a SambaPOS issue, and is why I suggest you put your efforts in getting it to show up in Putty. When you use Putty, are you setting the COM port and settings up correctly as well?

Since so far you can only get that test software to work, can you post screenshots of the other tabs of that test software - specifically settings and communication. Possibly something there we can advise based on those settings what else you can check in Windows to get it working in Putty first.

the thing that i dont understand is weight is coming up for 1 second well i will check baud rate again

The weight coming up for one second is, i guess, the weight value being entered into the numberpad field on the pos screen and automatically “entering”. Thats why it looks like it appears for a second, its actually entering the numbers into samba, but then you possible have no actio s and rules to tell samba what to do with that inputted number so nothing happens

I dont use scales and havent looked at the setup at all but if youre getting a number input in thepos screen thats my guess as to what is happening

The scale just puts in the quantity, e.g. 0.420. Then when you press the menu button it would add the item at the quantity that is entered by the scale. There is no rules or actions required for this.

So @Oguzhan_Ademir, based on your screenshots, it looks like scale is now on COM1? I assume you changed the port and are aware of this since your original post had it on COM3.

In Putty, make sure the COM port is matching. Also Baud rate is set to 4800, so make sure speed is set to 4800 and connection type is set to Serial. Below is image I copied from the other topic about scale integration - so where speed is 9600 you need to change to 4800.

I know you say it shows up one time in SambaPOS, however it is not working properly. So you need to first get it working in Putty then we can eliminate any possibility that the scale cannot communicate with your PC. So concentrate on that first!

Then, you also need to make sure the COM port baud rate is set correctly in Windows for the COM port you connected the scale to. You do this in Device Manager, expand Ports then view properties of the COM port scale is connect to. Go to Port settings in the dialog and you need to make sure the baud rate (or bits per second as it says in Windows) is set correct here - in your case to 4800.

I don’t have any COM ports on the PC I am using so I have just found the below image on Google. It shows the dialog for Windows 7, is pretty similar on 8 and 10. Your COM ports won’t be named same as the image, so just use for reference.

So try this out and let me know how you get on. Good luck! :slightly_smiling: