Scales Integration

Has anyone been able to integrate a Mettler Toledo Viva set of scales?



We don’t have direct integration with Mettler Toledo Viva.


That doesn’t mean it can’t be done though, yes?

In theory any scale that communicates over com port can be integrated

Thanks Jesse, I thought that would be the case. If I get it going I’ll post the solution.

First step is to connect to the COM port using PuTTY then you can see what the scale is sending. You may need to change some settings on the scale to determine what it sends and the format it comes in. Once you confirm what is being sent, you can then use the Custom Scale device type and use a RegEx to extract the data from what is being sent.

All the scales I’ve integrated I’ve had to use Custom Scale and work it out myself.

If you get stuck, try the first step and then you can share what data is being sent from the scale and we can advise on the RegEx

1 Like

Awesome, thanks.

I’m getting nothing at present but Google has told me (after ages searching, lol) that I probably need to connect it with a null modem cable. My adaptor should arrive tomorrow.

Let the games begin!

Yeah that is pretty normal. What were you trying to connect with previously?

It didn’t come with a cable so I bought a serial to USB cable ( ) but I can’t see any traffic. I’ve set the com port to the same settings as the scale. All I see is port open, port closed. I then bought a null modem adaptor, tried that but still no traffic.

I’m suspecting that the scales themselves are faulty at the interface level.

Honestly I have never tried using scales with a Serial to USB adaptor, I’ve always connected them to a POS terminal that had a COM port, so I cannot say whether they’d work with the USB adaptor. Do you have any systems that have a native COM port and try with that instead? I do know some Serial to USB adaptors can be quite problematic and buggy…

I’ve ordered a DB9 to RJ45 adaptor, the terminal PC has RJ45 COM ports.

Usually I’ve found when terminals come with RJ45 COM ports, the adaptors are included. But yeah that is your best option to try at first rather than the USB adaptor.

It was second hand as well. :pensive:

Got the scales to communicate with the PC. It needed the null modem adaptor. It’s also the type that needs an upper case W sent to it before it sends back the weight.

There is an action for sending the W.

There was an action mentioned in a tutorial but it doesn’t exist in my list. I’m on 5.3.0

The only ‘Send’ Action in my list is Send Email.

Looks like I’m upgrading soon SambaPOS 5.3.4 Release

Sorry it would only be in 5.3.6