"Select Customer" and "Select Table" buttons not present after upgrading to 4.1.54

Non of them there unless i select an item - then it appears.

“Ticket Creation Method” is “Create Ticket”, but i still need most of times to select custome/table first.

Verify the Ticket Type Entity Type List contains Customers and Tables

yes, all checked as should

OK solved, i unchecked and save, then checked and save - now it working…

Odd behavior that it would forget that setting…

Indeed, it also happened to me with printer template of the open drawer - i had to clear the template, then save, them fill the template back and save, and then it opened the drawer…

Hmm I have not experienced that error. It must be specific to your Database for some reason.

You probably migrated several times from older versions?

First i installed win7, framework 4.5 and sambapos 4.1.53 as sql compact - then it was OK.
The next day i converted to express 2012 with ExportSqlCE40.exe - it created 3 files - migrate_0.sql migrate_1.sql migrate_2.sql (my sdf file was almost 32MB so i run all 3 files.