[SOLVED] Something Strange with 4.1.58

I do have Change Price Button

whit his rule:

and the action:

It used to work great until today… I had to change a price… I clicked in the CHANGE PRICE BUTTON, as allways it ask for ADMIN PIN, then asked for the new price… so far so good… the problem is that it changed ALL TICKET ITEMS to the price I entered…

I used it on sunday with version 4.1.56 and worked without problems…



I’m checking it…

btw I was thinking I never released 4.1.56 lol.

Just part of your mind games with @gerlandog

I am curious @gerlandog is the button mapped to Order Line?

1 Like

ya, that was a special versionjust for me…


1 Like

@gerlandog what is the reason of adding Ejecutar Commando? What it does?

I think you can just remove that action and set [?Precio Nuevo] for Update Order action

Sorry I made a typo… will try again!!!


So what was [?Precio Nuevo] What is it doing with the input to that field? I know its price but what was the first action doing with it?


@Emre, Thans, your suggestion worked… now I have one less action and the rule works again as it did…

now a stupid question, what did change in this version, since on sunday I used it and worked great, and today it did change all items with the price?



the first action just ASKED the price…


I assume the second action was supposed to read that price first action asked? What I am asking… how was it storing it so second action would pull it up? Is that action an Execute Automation Command action?

yes sir!!

sorry I forgot to print this screen


So I am trying to understand why it would change price of all items… if you did not have it visible on order line and you were pressing it from Ticket… that could explain it. But if not… it could have been because the first action was switching it to the ticket screen. It might be something to do with the changes he made to fix some of the order tag screen behavior in a post few days ago. If that is the case… then technically you had it built wrong to begin with and it should never have worked before todays patch lol

I am just guessing

1 Like

I dont know why it changed all… I use it this way, I select one order and then press Change Price button. it used to change that order price…


I bet I am close on my hunch… you may have read it may not have… but there is a post with an odd behavior on order tags… and using them with automation command mapped to menu item. It was not refreshing screen. Im betting when Emre fixed that it broke your implementation… which it would have worked before todays patch using @emre solution back then as well.

Its not really a bad thing however… because technically the way you were doing yours was working… but it was actually not supposed to work if that makes sense. Now its fixed and it forced you to change yours to the way it should have been to begin with.

I could be completely wrong… it just makes sense to me that your first action to execute an automation command probably switched it off of the selected order screen and put it back on ticket view

1 Like

I’m not really sure how it worked but I think we can access [?Question] value with [:Question] tag :slight_smile: Makes sense as I’m storing them as a parameter but I don’t know how @gerlandog discovered that.

Something probably clears selection before action executes so it updates all lines. I’ll check that.

Yes I read that post, and yes, you may be correct…
Maybe my implementation was not entirely correct, thats why it used to work and stoped working now…

that raises a lot of questions about ALL my rules and actions… that today are working and maybe in a future they will stop working, not becuase @emre breaks thinks, but becuase @emre fixes things and I have a poor understanding of a correct behaviour…


Well its kind of subjective… neither way was really wrong. And I may be wrong… I just remembered him saying he tried something to fix that order tag issue… and I started to think… that involved automation command being executed from the same order line screen.

So that fix may have fixed the screen issue with that issue but broke your use of it in yours. But in the end it didnt matter too much because you could get yours to work still and the other one perhaps is still fixed as well.

Of course I could be completely wrong and the two are not related at all and reality is he dropped a piece of carrot on his keyboard and accidentally inserted a line of code.

1 Like

I’m the only one who does wrong things here. Hopefully I can correct them :slight_smile:


I have too much I am thinking about right now… dont give me more ideas to try stuff lol.

I already have about 20 ideas I want to try and I am getting them all jumbled up together when I start trying to do that stuff rofl.

nononoononon, you are WRONG sir… here, at my pizza place, the only one that is never correct, ITS ME… the owner


1 Like