Space button is not working

since a few days i am unable to use space and backspace button on samba pos 4 while typing
to use space button i have to press ctrl along with it , then it works (Ctrl+space)
how can i solve this problem
from Pakistan

Does it work in other applications, like Notepad?

Possibly your keyboard is broken. Try another…

Where in SambaPOS is it not working?

Sounds like your keyboard is possessed to me. Time for a new ghost free one.


yes my keyboard is alright, in sambapos 4 to use space i have to press ctrl along with space button it then it works,
but in note pad and on all other applications space button is working fine
seem like there is something went wrong in configration of samba pos on my system

SambaPOS works just fine with keyboards so it must be something configured on your computer. In fact keyboard input is controlled by windows not SambaPOS.

Sounds to me like a key is stuck… Typically the Ctrl or Alt key if stuck can cause this.


Have you tried an alternative keyboard to make sure its not the keyboard?

hmmm ok thak u i will check it for that

dear i am using space button while typing on all other applications its working fine, if there were something wrong with keyboard then i should create problem for me on all other apps as well , but there is nothing like thati have recently installed samba pos and i have done something wrong while editing or entering data into samba pos , before that everything was going fine i just want to know if somebody can help me to restore that settings so that i can use space button without pressing ctrl along with it

Take it or leave it, as kendash said SambaPOS only reacts to keystrokes which are received from keyboard to windows and passed to Samba.
For the sake of trying an alternative keyboard from another computer to check before messing with settings and windows…
Would be the first thing i would try given keyboards are 10 a penny and most people have a spare one kicking arround.
Either way, whats the worst that happens, it does the same and you rule out the keyboard being the problem.
You would kick yourself if you spend hours messing with settings to later find out it was the keyboard.
If you dont know the problem is always good to rule out the simple things first :wink:


ok i will try it thnx