SQL database suspect

My database is showing suspect, I have done all I know to do but it’s loading as if it’s fresh.

Can anyone help recover/repair the database file as I don’t want to lose the information on it.

Thank you

Well you co nection steing shows a different database to the one marked as suspect.
Your getting two things confused.
The suspect db isnt whats making it apear as fresh. Would guess your string got changed and so has started a fresh database with new db name in string.
Re suspect db, youll need to reffer to sql forums for that one. If sql db is corupted thats not something samba can resolve, youll need to use sql tools to try and resolve. Did you not have any backups in samba? Posibly try and export and re import within sql manager but as said youll be better on an sql forum for that side of things, sql is a completly other software sambapos just uses the db it serves.

execute this in a query window:

USE master;

EXEC sp_resetstatus 'sambaPOS';

I have executed this and it was successful but still can’t connect

Also sql server failed to start

Is sql service isnt running samba has no chance, you need to sort sql before even trying samba…

And - what does the event log say?

You may want to ask on Microsoft support page.

Thank you very much for the help.

824 (the event id) usually indicates faulty hardware (hard drive, controller, etc.)

For something like this, you’ll want to start looking around google/stackoverflow as there are various ways to try and fix this (if it’s even possible).

If you don’t have a good backup and the data is critical, you might have to reach out to a company that provides a service to retrieve the data.


Thank you so much memo, I have been able to recover the database. I copied the database out before formatting and the reinstalled

sambapos software and then copied the database file back and it worked, but I have now having issues linking the second terminal with the same string on the server it isn’t connecting. I am using windows 10 on both, I have even turned off firewall. Still same issue

Take a look at the log file in the user’s SambaPOS folder - the full exception should be logged there which will offer specifics of the connection issue.

Your original posts looks like you were running W7, but now W10 suggesting a fresh install of windows when you say “reinstalled”. You’re using the machine name in your connection string. So make sure whichever terminal is running SQL Server has the same machine name “RoyalFoods1” - or set a static DHCP reservation and use that IP address in lieu of machine name.

Seeing as this is a potentially new install, make sure that TCP/IP and Named Pipes are enabled for the SQL Server engine and that ports are configured to 1433.

Thank you so much. Yes the Terminal with SQL is named ‘RoyalFoods1’. I had thought of changing the TCP/IP to static but I felt that shouldn’t be an issue and was concentrating on the firewall. Thank you so much I would change it to static and revert.

Yes, I was on W7, I realized that the reason why the sql server was sent starting is because the terminal was infested with virus/worms that renamed the sql files which also made it impossible to repair. Too many files were renamed so I felt the only solution was to change the OS and since W7 is no longer supported by Microsoft.

How do I enable TCP/IP and Name pipes for SQLServer engine? Kindly point me in the direction to go. Thank you.

SQL Server Configuration is where you want to go


Named pipes, enabled

TCP/IP enabled

for each IP Address/interface defined, be sure “TCP Dynamic Ports” == 0 and “TCP Port” == 1433

Thank you so very much it worked. I am very grateful!

1 Like