SQL issues again

So I went off to sunny spain again and had 2 instances of the server not booting on startup which is a pain, cos i was in the bar at the time getting slightly inebriated.

Both times were because of power cuts that turned the tills off.

Has anyone found a solution to sort this problem yet? its getting a bit frustrating now, especially as it impairs my sun and booze time lol


UPS first of all :stuck_out_tongue: We have them on virtually everything, little chap ones will do a basic pc for maybe 10-15 mins, enough for most senarios.
At least that will eleiviate the problem as sourse till you can resolve the soft issue.

@GreatShakesBar have you tried upgrading to SQL Express 2016?

no… sounds scary lol

Ill give it a bash Sunday when I’m closed, ill let you know how I get on.
UPS is something i want.


1 Like

Lol nothing scary about it. You simply start the installer and choose upgrade… it typically goes smooth 99% of the time. I have heard it fixes this issue. Besides you can always just backup before you do it.


Just so i do get the right download link… is there a chance someone could post what I need?

I downloaded almost every SQL server from the microsoft website lol


Sql express 2016 is all you need.

1 Like

try not to reply too quickly, i might take advantage :joy:

Thanks loads, I hope this solves the issues in 3 locations!


Sorry to bump, “APP NOT COMPATIBLE WITH THIS VERSION” I get popping up…

Im running windows 10… tried compatibility but still nothing… i know this isnt SQL forum, but does anyone know whats happening here?


Means you need to update your mssms tools. Download latest version of tHe management tools.

Ugh I really gotta stop looking at forym and driving… voice to text not too good.

1 Like

Lol :joy::joy: thanks.

Will give this a go Sunday.


Have you updated to 2016?
Maybe check in all programs, I ended up with 2012 and 2014 installed and they both have managment tools installed, just make sure youve not got a shortcut or something for older tools.

1 Like

MY till is 32 bit with a 64 processor…

Looks like I’m going to have to upgrade windows to 64 bit to stop my till from having these issues.

luckily all the other tills ive made are 64 bit… sigh lol

What brought you to that conclusion?
32bit os should run without issue on a 64bit machine… You just can’t utilise the benefits like more that 3gb ram…

I bought it pre loaded

Oh wait… no I google it. U can’t put sql 2016 on a 32 bit

Pretty simple solution. I can download windows 64bit with the key preloaded from my till system. W10 allows that or something.

COA numbers are bit unaware, they are version specific not 32/64 specific.