Strange printing output using Star SP700

I have a strange issue with print output on a Star SP700 impact printer, connected via Serial. Recently installed a new POS system with SambaPOS v5 and the client wanted to use their existing SP700 kitchen printer. They assure me the previous POS did not have this issue (it was an old proprietary system not using Windows).

Here is the output from SambaPOS for the kitchen ticket:

Self test from the printer is perfect without this issue.

OS is POSReady 7 (i.e. Windows 7 32bit), Using SambaPOS v5.1.60. I am using a slightly older version of the SP700 printer driver because the latest version requires .NET Franework 3.5 and I was unable to install that (because of restrictions set in the POSReady 7 system image I have. On POSReady 7 you cannot set Windows features via control panel, they need to be enabled using the master install CD when first creating the image. There are ways around this however I chose to avoid it in this instance as the older driver didn’t have that prerequisite requirement).

Windows print test page doesn’t print correctly (just prints random characters) however I have seen the same before and generally related to printers connected via serial. I don’t think this is related.

Printer is connected via a long (10m+) serial cable. The settings on the printer when I did the install were set to 9600bps so I just left as is (I think this might be due to the length of cable so to reduce any errors in communication). All settings match on COM port in Windows.

SambaPOS prints fine other than the strange output. It looks like some misalignment between when the print head prints in left and right directions as it prints in both directions (bi-directional). I have tried to turn off bi-directional support via the driver but it either makes no difference or is being ignored as output is the same.

I am sure this isn’t an issue related to SambaPOS but would like to know if anyone has seen this sort of issue and how they resolved it, or if anyone has any suggestions on what I can try?

What about printing in standard height, not double height?

I think it’s fine actually. I didn’t test that explicitly, however you can see in the image, the date/time is standard <L00> and prints fine.

So possibly the printer has an issue with double height characters?

I don’t have the printer here to test, and it’s at client’s busy restaurant so not in a position I can play around more and test, just need to find a solution or try to sell them a new printer. They need large text in kitchen, standard height isn’t large enough for them.

Anybody got a SP700 and care to test ? :wink:

Oh yeah I miss that.

So, driver, connection should be OK. I think printer itself maybe the issue.

I feel like in your problem that would be easiest, kitchen printers are relatively cheap and an issue like that could take ages to find the fix for.

1 Like

Looks like it have an alignment setup.

1 Like

Thanks very much Emre, I never knew such mode existed! This definitely looks like what the problem is, will visit the client in the next few days and test this out, hopefully can fix it. :slight_smile:

@emre I tried this out today and worked perfectly! It was really misaligned, had to repeat procedure of selecting best option twice (the printer had slightly different procedure than the manual you referenced). :smile:

1 Like