Sub menu on drink menu with pages, not filling

#1

In the cocktails menu there are sub menus. Several act odd to me.
When using pages, why doesnt it fill the area before moving on to next page?

RUM sub menu for example. I only have 4 rums. It will show 2 on page one and 2 more on next page. Why not all on that one page?

07%20AM

22%20AM

0 Likes

#2

You might be set column count of this category as 2. If you select column count as 2, it will be applied to all sub categories as 2.
Also there is a setting about page count on the Edit All Categories. If you determined page count as 2, it will set sub category pages 2 as well.

0 Likes

#3

No I have it set to four.

0 Likes

#4

Show your settings so we can spot your mistake.

0 Likes

#5

35%20AM

48%20AM

See----four columns

11%20AM

0 Likes

#6

It’s because you set it to page count 2 so it’s evenly distributing it. Try setting page count to 0

0 Likes

#7

Sure that works, but thats how it was by default. I wanted pages to avoid scrolling. Scrolling would be fine, but the scroll bar is way to small for a touch screen. It really needs to fill page one before proceeding to page two.

scroll

0 Likes

#8

So set column to 0 and page to 2 see what that does.

0 Likes

#9

Back to square one. Under RUM it only puts 2 items on page one and 2 items on page two.
Also not that its doing alphabetical, and its like its one html table/row and they are in order. This seems like a bug.

(4 item)
SUB CAT = RUM
PAGE ONE
Bacardi light Captain Morgan

PAGE TWO
Malibu Myers

0 Likes

#10

Also with your settings column to 0 and page to 2 its STILL scrolls

PrtScr%20capture_2

0 Likes

#11

It may not be possible for what you want then. I don’t recall a setting to allow it to fill a page. Try only using it for specific categories and not all of them.

0 Likes

#12

Well that is a bummer.

0 Likes

#13

Try setting button height to zero i think that spaces the button height to fit, im sure I’ve done that on mine

0 Likes

#14

That does work at getting rid of the scroll. However I like consistency and going from buttons that are 100 in height to what looks like 500 in height on some items just will not cut it with me and my ocd.

I had a revelation. I changed my sub menu row count to 3 and broke my longest catagories into more sub menus. Now there are two bourbon buttons and two specialty page buttons. This will be easier for the waitresses.

HOWEVER
How can I put those in a set order?

I would like the two bourbon buttons to be next to each other.

cocktails

0 Likes

#15

In the menu setup you should be able to arrange alphabetically or if you look at each product button there is a number assigned to each one and that is the order they are displayed in if you don’t use alphabetically, usually looks something like 10, 20, 30, 40 etc next to each product

Just change the numbers around for the positions you want the buttons displayed

0 Likes

#16

They are ordered by the first product with the submenu…
It is an unfortunate side effect of submenus I think that it distributes rather than fills page.

0 Likes

#17

That only works for the buttons in green, not the yellow sub categories they are under.

0 Likes

#18

No I take that back, I did get that to work but I am questioning it.

The sort order numbers are pretty broad, semi sequential.

I was able to modify just the first number of page 2 on any catagory to follow the number on page one and it works, but should I change all of the page one and page two sort order numbers?

Its working with just one edit. Will it be ok to leave it like that?

PrtScr%20capture_4

PrtScr%20capture_5

PrtScr%20capture_6

1 Like