Think there is an issue using [?Prompt] in a {CALL:x()} or ANYWHERE in the flow where script call uses a value based on that value

Am using {CALL:x} to run a script needs a value for account to charge to.
Have three rules in the flow;

  1. [?Prompt] for the account into ticket tag & execute command 2
  2. Save ticket and run script using ticket tag and ticket id in command to trigger 3
  3. Process script response (command value from 2)

This woks fine in the room post script where the account comes from {ENTITY DATA:x}
Hmmm… although the room post doesnt use the [?Prompt]

Grrrr, its the [?Prompt] changed the prompt to a string/number for the account instead and worked :frowning:
Need a prompt though…
Any suggestions?

Custom task with validation prompts and the execute custom task action.

1 Like

Not familiar with custom task, could you elaborate breifly to give me a headstart?

In fact you could use custom task to chain different things together using validation inside the task.

It’s a theory I’ve not tested them like that yet. I’ve used validation before but not like that. But it could work.

Program setting doesn’t work either, defiantly [?Prompt] issue, have used prompt many times without issue when not using script based on prompt value…

:grinning: setting the execute command to background solves :smiley:

OR at least it was :frowning:

Banking my head against the table right now…
It wasnt the prompt, was the save ticket action, used tag to allow save ticket without entity but forgot to add the tag in ticket settings to allow the ticket to be closed :frowning:
The background made no difference it was that I must have tried posting an ticket on an entity meaning close/save was posible.
The script also needs the ticket ID.