Turkish Character Problem


I’m using the latest version of SambaPOS and thermal printers (xprinter xp80c). I’ve tried all 4 different Turkish character sets in the sambapos printer configuration screen (dos, iso, mac, windows). However, none of them didn’t work. When I print the printer’s self test document, printer successfully prints all turkish characters like ş,ğ, ç. and printer’s code page sets to 61: PC857(Turkey).

Also I’ve tired to '‘change characters’ options in sambapos printers configuration window, like ç=c, ğ=g etc. it didn’t work too.

Pls help me :slight_smile:

You need to also change the character set on the printer, then set the matching setting in SambaPOS.

To change on the printer, you should have a tool that came with the printer (or you can download from the manufacturers website) that will enable you to change the character set.

1 Like

I’ve already tried this on printer. It’s character set is by default turkish set. So, it’s not working :confused:

If you do a test print (turn printer power on while holding down feed button), which character set is shown in use on the printout?

Page:61 which is PC587(Turkey)

I also tried to Codepage: 79 PC3846 (Turkish)