Urgently Need Help: Print Job intermittently delayed/staled

I would go ethernet for the u220b. Doesn’t that go in the kitchen anyways so away from the pc, dont tell me you got a long usb cable hooked up to it. Anyways this is an odd problem buying an ethernet module for it “might” fix your issue. To be sure hook up the usb printer to another pc with samba and see how it performs.

Ethernet Module for you printer

1 Like

I use the generic Driver “Generic/text only”. It has worked for me with USB drivers when windows 7 does not like them.

It might help to look in Device Manager > USB > Properties > Power Management and ensure that all USB ports have “Allow the computer to Turn Off this Device to Save PowerUNchecked. You may also want to modify overall Power Management settings for the Computer to ensure that it is set to “Always On”, especially in the case of running a POS system.

1 Like


Your initial problem can be resolved by doing what @QMcKay recommended. I am assuming this printer is not shared to another computer. If it is shared, you need to stop sharing and buy an Ethernet printer to print directly to printer.

Your issue with printer not being recognised can only be resolved by doing a System Restore to a point where printer was not installed or it was working properly.

No matter what you do, you will not get this printer recognised by Windows again if you do not perform a System Restore.

This printer can not be connected to your computer when you install the driver or update the driver.

I had the same issue and spend 6 hours trying to figure it out.

For this reason alone, I really dislike this printer.

Next time by a SRP-275 and this works flawlessly.

Let us know if you get it resolved.

Good luck.

Ok so basically I’ve tried Isaac suggestion to use a shorter USB cable, and so far it has worked without getting unrecognised again, fingers crossed. But let’s see tomorrow, because it was only for the last few transactions. I wonder why they provide such a long cable if it were going to create a problem.

@Hasa Thanks for the suggestion, I need to look around if anyone is selling the add-ons here locally. No I didn’t have time to set up the printer in the kitchen, so the POS is purely for payment processing.

1 Like

@QMcKay Thanks for this. Apart from changing to shorter USB cable, I did go to Power Management and found out there’s a Suspend feature for USB being enabled, and I disabled that. I am not sure if this is the same as your screen but I will definitely check that out as well later today.

@na1978 The printer is not shared, and the funny thing is, before I purchased this printer, I looked around for some review and found out about the issue when the printer is connected before driver is installed. So I did take caution and prep the laptop with the right driver even before I unbox the printer.

I am hoping my issue wasn’t the driver but with the USB power and cable length. Lets see today if there’s anymore complaint.

I really appreciate all your help. Couldn’t ask more from an awesome and “free” app than a nice and prompt community.


Yeah, stay away from longer then 3-4 ft usb, if you need length in my opinion ONLY ONLY ONLY ETHERNET. When the printer is righ next to the computer then serial or usb. Also stay away from converters I really dont like them. From my experience never try to make something work with third party equipment. Go straight to epson and do it through their equipment only as that will be most reliable. @bleach

i am also facing the same issue in both the POS machine installed in my restaurant. Both the printers connected with USB cables stalls when system is kept idlefor some time.

Let me also try these solutions discussed here and see if it works.

will keep posted.

Just an update. It’s been a few days since I fixed the issue and it seems to be fixed for good this time, no more stalling.

So to conclude (assuming you install the driver correctly the first time like I did) :

  1. Try NOT using long USB cable. Ditch the one that came with the box, it’s pretty long.
  2. Edit your power setting to make sure USB suspend feature is disabled.

Thanks again for all your help and I hope this can help others with the same problem.



Hi All. i have been using sambapos for less than 24 hours now.

one issue i have encountered is, when i process a payment through the settle button, once i click cash, it take a good 10 seconds for the action to process and the till draw and receipt open/prints late.

for some strange reason when i click the “open drawer” button directly the till opens immediately only when i use the cash button it takes long and delays the print job and cash drawer.

my printer is epson tm-t88iip and it is connected to my epos system via serial, the cashdrawer is connected to the printer.

Which version are you running? v4.1.82 ?

Which Database is in use? TXT, CE, SQL (LocalDB or Express)?

Have you made any / many modifications to the system?